Transmission problem?? - Page 2 - Subaru Outback - Subaru Outback Forums
Reply
 
LinkBack Thread Tools Rate Thread
post #11 of 11 (permalink) Old 11-28-2012, 05:45 PM Thread Starter
Registered User
 
Join Date: Sep 2012
Location: NC USA
Car: 2005 Outback 2.5i
Posts: 9
Feedback Score: 0 reviews
1 LuckyTexan and MRK610 were right. The noise kept getting louder and louder from the rear right side. Had a friend ride with me to make sure I was not going crazy. Took it to the local Subaru dealership and they agreed; doing the warranty work as we speak with no hassle. Thanks so much for your replies.
timelord74 is offline  
Sponsored Links
Advertisement
 
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Subaru Outback - Subaru Outback Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Random Question

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Rate This Thread
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome