Turbo Cuts Out - Subaru Outback - Subaru Outback Forums

SubaruOutback.org is the premier Subaru Outback Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Rate Thread
Old 11-10-2012, 10:38 PM   #1 (permalink)
Registered User
 
Join Date: Nov 2012
Posts: 2
Feedback Score: 0 reviews
Default Turbo Cuts Out

I have an '06 OBXT with just under 90K miles. About two weeks ago while driving on the freeway I was giving it some gas and it seemed like someone had pulled the engine out for a second and the CEL came on with flashing cruise light. I took it in to my regular mechanic and he told me the code was for a waste gate sensor which he replaced and the problem happened again on the way home from picking it up. I took it back and he looked at it again and stated that there was a problem with a valve (he said it was more like a diaphragm) and was holding sometimes and sometimes it wasn't. Told me that that can't be replaced but the entire turbo would need replaced. I went and picked it up.

Drove it to work today and hammered it as much as possible to try and duplicate the condition. It seems to happen when the RPMs get to around 4000. Any suggestions? Should I take it back to my regular mechanic and get a new turbo, or should I take it to the dealership and let them have a crack at it?

Thanks in advance!!!
Yinzpgh1 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-10-2012, 11:52 PM   #2 (permalink)
Registered User
 
1 Lucky Texan's Avatar
 
Join Date: Jan 2004
Location: behind the Krell Metal door
Car: 03 H6 OBW & 06 WRX Sportwagon
Posts: 7,302
Feedback Score: 0 reviews
Default

what are the codes?
__________________
Time Flies Like an Arrow,
Fruit Flies Like a Banana!
1 Lucky Texan is offline   Reply With Quote Quick reply to this message
Old 11-11-2012, 12:16 AM   #3 (permalink)
Registered User
 
Join Date: Nov 2012
Posts: 2
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by 1 Lucky Texan View Post
what are the codes?
I don't know. The mechanic only told me that the code was telling him that it was a problem with the turbo. He didn't tell me what the code was though.
Yinzpgh1 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Subaru Outback - Subaru Outback Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 04:15 AM.



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.3.2
Copyright 2009-2010 SubaruOutback.org. All Rights Reserved.