Backup Camera not working - Subaru Outback - Subaru Outback Forums
 
LinkBack Thread Tools Rate Thread
post #1 of 8 (permalink) Old 07-24-2013, 04:18 PM
parser
Guest
 
Posts: n/a
Backup Camera not working

baruistas,

I have a 2011 Outback with backup camera, purchased in USA, but now living in Canada. Backup camera not working and local deal couldn't troubleshoot a solution in the time they had my car.

I read and tried the solutions posted in this thread:
http://www.subaruoutback.org/forums/...t-working.html

But power on / off not my problem -- tried numerous times to power on/off and didn't say 'fixed' for long.

Symptoms: Occasionally get 1) it working properly; or 2) get blue screen with the grid outlined temporarily while in reverse, but no image; or 3) simply no blue screen or image (lately). Coincidentally and possibly related -- seemed to go on the funk during recent wet weather period but that could just be spurious coincidence.

Anybody have this problem and could share what caused / solved it? Will bring the car in again to get it better diagnosed, but surprised local dealer seemed clued out first time around. Seems that the backup camera not a common option here where I get my car maintained.
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 07-25-2013, 07:29 AM
Registered User
 
Join Date: Jul 2013
Location: Trumbull, Connecticut
Car: 2007 Outback LTD
Posts: 36
Feedback Score: 0 reviews
Had the same symptoms that you mentioned and it turned out to be the camera itself, I fitted a new one and all was well. Hope this helps.
fod1 is offline  
post #3 of 8 (permalink) Old 10-13-2014, 05:20 PM
Registered User
 
Join Date: Oct 2014
Posts: 2
Feedback Score: 0 reviews
backup camera not working

2011 Outback with factory backup camera. When shifted in reverse, blue grid appears for a few seconds and then disappears. No image appears. Camera no good as previously written? Looks like a large pain to replace due to disassembly of the whole tailgate. Would appreciate confirmation of diagnosis before I start repair. Thank you.
jfoutback11 is offline  
post #4 of 8 (permalink) Old 10-13-2014, 08:27 PM
Registered User
 
Join Date: Jul 2013
Location: Trumbull, Connecticut
Car: 2007 Outback LTD
Posts: 36
Feedback Score: 0 reviews
Sounds the same as a few I've replaced at work, I'd bite the bullet and go for the camera. I have disassembled the ones I've replaced and they've all suffered from water damage! Hope this is of some use to you.
fod1 is offline  
post #5 of 8 (permalink) Old 10-14-2014, 12:22 AM
Registered User
 
sirtef9's Avatar
 
Join Date: May 2010
Location: Colorado Springs
Car: 2000 Subaru Outback Limited
Posts: 416
Feedback Score: 0 reviews
Have you had your windshield replaced lately?

2000 Outback limited
1992 Integra GSR turbo
sirtef9 is offline  
post #6 of 8 (permalink) Old 10-14-2014, 04:06 PM
Registered User
 
Join Date: Oct 2014
Posts: 2
Feedback Score: 0 reviews
Thank you for confirming my suspicions. Subaru should really incorporate a weatherproof camera/housing for such a vulnerable spot. $30 camera and hours of tear down and assembly. Oh well.
jfoutback11 is offline  
post #7 of 8 (permalink) Old 12-09-2014, 02:51 AM
Registered User
 
Lezleefeetsgoddess's Avatar
 
Join Date: Dec 2013
Location: Ohio
Car: 2013 Outback 2.5i Limited...
Posts: 4
Feedback Score: 0 reviews
2013 Outback 2.5i Limited. Had my camera replaced yesterday. Started acting up about a week ago. Sometimes the display just stayed on GPS, other times Black Screen with the alignment lines, other times it worked fine. I have the extended warranty and was shocked that it covered that. $0.00, I like that. They said it would have been around $500 or more if not covered.
Lezleefeetsgoddess is offline  
post #8 of 8 (permalink) Old 12-09-2014, 03:20 AM
Registered User
 
Join Date: Dec 2014
Posts: 6
Feedback Score: 0 reviews
I'd bite the bullet and go for the camera.
ilaurenzv is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Subaru Outback - Subaru Outback Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Rate This Thread
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome