Knock sensor PO 328 experience?? - Subaru Outback - Subaru Outback Forums

SubaruOutback.org is the premier Subaru Outback Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Rate Thread
Old 06-04-2007, 05:59 PM   #1 (permalink)
High mileage
 
Join Date: Mar 2005
Location: CT
Posts: 248
Feedback Score: 0 reviews
Default Knock sensor PO 328 experience??

Hi Guys. I have seen lots of PO325 info here, but does anyone have experience with the PO328 "Knock sensor 1 circuit high input" error code? The CEL comes on and off during the last 500 miles or so on my '00 OBW 2.5l with 106,000 miles. BTW, it runs great and gets over 30 MPG highway.
__________________
'08 Legacy Limited, 2.5 Auto, 43K
'00 OB Wagon 2.5 Auto; 151K
'98 SUS sedan 2.5 Auto; 196K (sold it-RIP)
'97 Brighton 2.2 5spd; 152K (sold it-RIP)
'96 OB Wagon 2.5 Auto; 200K
'99 Windstar 3.8l; 147K
'07 Honda Civic 1.8l; 53K
Scubytwo is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-05-2007, 01:36 PM   #2 (permalink)
High mileage
 
Join Date: Mar 2005
Location: CT
Posts: 248
Feedback Score: 0 reviews
Default

I inspected the knock sensor and found a cache of nuts and seeds packed around the sensor (a wintering mouse no doubt). This could have been helping to alter the noise & vibration levels local to the sensor and causing the sensor to false report. The CEL is now off. I will see if the light stays off and report back.
__________________
'08 Legacy Limited, 2.5 Auto, 43K
'00 OB Wagon 2.5 Auto; 151K
'98 SUS sedan 2.5 Auto; 196K (sold it-RIP)
'97 Brighton 2.2 5spd; 152K (sold it-RIP)
'96 OB Wagon 2.5 Auto; 200K
'99 Windstar 3.8l; 147K
'07 Honda Civic 1.8l; 53K
Scubytwo is offline   Reply With Quote Quick reply to this message
Old 06-06-2007, 05:53 PM   #3 (permalink)
ETC
Registered User
 
ETC's Avatar
 
Join Date: Jan 2007
Location: Southern Ca
Car: 00 OB 07 OBXT
Posts: 5,531
Feedback Score: 0 reviews
Default

apparently the knock sensor also picks up mouse squeels ;] potential ground hog locater ....................

sometimes it's as simple as cleaning something.
ETC is offline   Reply With Quote Quick reply to this message
Old 06-06-2007, 07:47 PM   #4 (permalink)
High mileage
 
Join Date: Mar 2005
Location: CT
Posts: 248
Feedback Score: 0 reviews
Default

That did not solve the problem. It must be a bad sensor. Be back with the report/
__________________
'08 Legacy Limited, 2.5 Auto, 43K
'00 OB Wagon 2.5 Auto; 151K
'98 SUS sedan 2.5 Auto; 196K (sold it-RIP)
'97 Brighton 2.2 5spd; 152K (sold it-RIP)
'96 OB Wagon 2.5 Auto; 200K
'99 Windstar 3.8l; 147K
'07 Honda Civic 1.8l; 53K
Scubytwo is offline   Reply With Quote Quick reply to this message
Old 07-19-2007, 09:15 AM   #5 (permalink)
High mileage
 
Join Date: Mar 2005
Location: CT
Posts: 248
Feedback Score: 0 reviews
Default

Reporting back that I did replace my knock sensor, which was very easy on a 2000 OBW, and the CEL has been off for some time now-even using regular gas.
__________________
'08 Legacy Limited, 2.5 Auto, 43K
'00 OB Wagon 2.5 Auto; 151K
'98 SUS sedan 2.5 Auto; 196K (sold it-RIP)
'97 Brighton 2.2 5spd; 152K (sold it-RIP)
'96 OB Wagon 2.5 Auto; 200K
'99 Windstar 3.8l; 147K
'07 Honda Civic 1.8l; 53K
Scubytwo is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Subaru Outback - Subaru Outback Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 07:58 AM.



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.3.2
Copyright 2009-2010 SubaruOutback.org. All Rights Reserved.