Low Beams Not working on my Outback - Subaru Outback - Subaru Outback Forums

SubaruOutback.org is the premier Subaru Outback Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Rate Thread
Old 10-15-2007, 12:33 PM   #1 (permalink)
Registered User
 
Join Date: Oct 2007
Location: Colorado Springs
Car: 1998 Subaru Outback
Posts: 7
Feedback Score: 0 reviews
Default Low Beams Not working on my Outback

My low beams stopped working a few days ago on my 1998 Outback. I didn't notice a separate fuse for the low beams but may have overlooked it.
Is it possible that the dimmer switch is bad and would that be a good place to start?
I'll check out the relays for the headlights and see if there is an answer there.

Any help would be appreciated.

thanks, Chris
cwdonihi is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 10-15-2007, 05:23 PM   #2 (permalink)
Registered User
 
Join Date: Oct 2007
Location: Colorado Springs
Car: 1998 Subaru Outback
Posts: 7
Feedback Score: 0 reviews
Default

OK- turns out that both bulbs need replacing. I'm not sure at this time if they both blew at the same time or I was running with one lamp. Both bulbs were replaced about 1.5 to 2 yrs ago if I remember.
If they blow again I'll follow up. I did use the Sylvania brand.
cwdonihi is offline   Reply With Quote Quick reply to this message
Old 10-15-2007, 06:30 PM   #3 (permalink)
Registered User
 
Join Date: Jul 2007
Location: Lac Ste. Marie, Quebec
Car: 1997 SVX Bordeaux 2012 OBW 6 speed 1992 SVX Ebony 1992 SVX Claret
Posts: 1,091
Feedback Score: 0 reviews
Default

Were they Silverstars? They usually blow quite quickly and close to the same amount of hours.
Try Osram Silverstar.
Blacky is offline   Reply With Quote Quick reply to this message
Old 10-15-2007, 08:01 PM   #4 (permalink)
Registered User
 
Join Date: Oct 2007
Location: Colorado Springs
Car: 1998 Subaru Outback
Posts: 7
Feedback Score: 0 reviews
Default

Yes they were- Thanks for the advice.
cwdonihi is offline   Reply With Quote Quick reply to this message
Old 10-15-2007, 08:13 PM   #5 (permalink)
I :heart: SUBARU
 
porcupine73's Avatar
 
Join Date: Aug 2006
Location: Buffalo, NY USA
Car: '00OBW, '96&'94 Legacy
Posts: 4,722
Feedback Score: 0 reviews
Default

Yes Sylvania Silverstars didn't last too long for me either. Osram Silverstars are the real deal. Check out www.danielsternlighting.com for toonnss of great lighting info.
porcupine73 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Subaru Outback - Subaru Outback Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 08:23 PM.



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.3.2
Copyright 2009-2010 SubaruOutback.org. All Rights Reserved.