Gas tank won't take gas....??? - Subaru Outback - Subaru Outback Forums

SubaruOutback.org is the premier Subaru Outback Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Rate Thread
Old 07-07-2011, 03:04 PM   #1 (permalink)
Registered User
 
Join Date: Jul 2011
Posts: 2
Feedback Score: 0 reviews
Default Gas tank won't take gas....???

I have a 2004 Subie Outback with 80K on her. For the last year or so I have had an on-again/off-again issue with filling my gas tank. As I try to pump gas into the tank after 2-3 seconds the pump will shut off and gas will spray back at me from around the hose nozzle. Then whatever gas I pumped into the tank will surge back up and pour out of the tank opening. It's as if there is some valve that is not opening to allow ventilation for fill up. I took it to my Subie specialist who said he'd never heard of such a thing. He changed a fule sensor and cleaned out my fuel tank valve thinking that was it. It wasn't. It will not happen all the time and there seems not to be a trigger. Type of pump (vapor sleeve vs. non-vapor sleeve) makes no difference, whether the tank is empty, half full, 3/4 full does not matter. Sometimes the check engine light comes on, sometimes not. I ran out of fuel on the way home and was able to sneak 2.5 gals from a gas can and then took it to the station to fill and it worked whereas my 4 attempts to fill her over the previous 3 days failed. Engine light was on code P0457 Evaporative Emission Control System Leak Detected. Any ideas?
SolidRockRanch is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 07-07-2011, 03:12 PM   #2 (permalink)
Registered User
 
Join Date: Jun 2008
Location: San Francisco
Posts: 15,127
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by SolidRockRanch View Post
I have a 2004 Subie Outback with 80K on her. For the last year or so I have had an on-again/off-again issue with filling my gas tank. As I try to pump gas into the tank after 2-3 seconds the pump will shut off and gas will spray back at me from around the hose nozzle. Then whatever gas I pumped into the tank will surge back up and pour out of the tank opening. It's as if there is some valve that is not opening to allow ventilation for fill up. I took it to my Subie specialist who said he'd never heard of such a thing. He changed a fule sensor and cleaned out my fuel tank valve thinking that was it. It wasn't. It will not happen all the time and there seems not to be a trigger. Type of pump (vapor sleeve vs. non-vapor sleeve) makes no difference, whether the tank is empty, half full, 3/4 full does not matter. Sometimes the check engine light comes on, sometimes not. I ran out of fuel on the way home and was able to sneak 2.5 gals from a gas can and then took it to the station to fill and it worked whereas my 4 attempts to fill her over the previous 3 days failed. Engine light was on code P0457 Evaporative Emission Control System Leak Detected. Any ideas?
This can happen when the vent valve gets stuck. Not a common issue but also not an uncommon issue either. The fix is to replace the vent valve the down side it it generally involves some labor time to get to it.
subiesailor is offline   Reply With Quote Quick reply to this message
Old 07-07-2011, 04:38 PM   #3 (permalink)
Registered User
 
Join Date: Jul 2011
Posts: 2
Feedback Score: 0 reviews
Default

Thanks - I'll share the info with my mechanic.
SolidRockRanch is offline   Reply With Quote Quick reply to this message
Old 07-22-2011, 02:17 PM   #4 (permalink)
Registered User
 
Join Date: Oct 2010
Location: Central OH
Car: 1999 Subaru Legacy Outback
Posts: 133
Feedback Score: 0 reviews
Default

Any resolution for this one? I have same issue with '00 Forester. I've finally resolved to dropping the tank at some point because it seems like vent line to Evap canister is clogged (spider webs?) - but my daughter swears that sometimes it takes gas normally. Weird.

Thanks,
Wally
wallyblackburn is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Subaru Outback - Subaru Outback Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 10:29 AM.



Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.3.2
Copyright 2009-2010 SubaruOutback.org. All Rights Reserved.