Subaru Outback - Subaru Outback Forums

Subaru Outback - Subaru Outback Forums (https://www.subaruoutback.org/forums/)
-   Gen 5: 2015-2019 (https://www.subaruoutback.org/forums/138-gen-5-2015-2019/)
-   -   The I Put Wheels From Tire Rack on my 2019 and Got TPMS to Work Thread (https://www.subaruoutback.org/forums/138-gen-5-2015-2019/501701-i-put-wheels-tire-rack-my-2019-got-tpms-work-thread.html)

GrumpySquatch 11-10-2018 06:51 PM

The I Put Wheels From Tire Rack on my 2019 and Got TPMS to Work Thread
 
TL;DR version:
  1. Order wheels and tires from Tire Rack. Tell them you have a 201X Outback (2018 or 2019).
  2. Also buy an Autel TS508 TPMS tool.
  3. Use the TS508 to wake and read the sensors. Then follow the OBD Position Relearn procedure for a 2018 Outback on the Advanced menu of the TS508 to program the new sensor IDs into the ECU via the OBD2 port.
  4. Drive the car for a few minutes and a few miles above 30 KPH (~19 MPH).
  5. Profit!

Background:
For the 2018 model year, Subaru changed the TPMS sensors on several models including the Outback. The main difference was a switch from sensors operating on the 315 MHz frequency band to ones operating on the 433 MHz band. The practical change was also a move from an "overall pressure" display that showed an error if any wheel was below the pressure threshold to showing pressure for each individual wheel. @Brucey recently started a thread to document this here.

This move seemed to take the industry by surprise and the old do-it-yourself tools that worked to manage previous TPMS systems on Gen 5 Outbacks no longer worked. Even worse, some of the aftermarket sensors no longer worked either, so many owners who change their wheels seasonally and others like me who prefer do-it-yourself maintenance were left out in the cold for a good 18 months with no way to update our systems. Lots of people including @Jimusoke, @Fibber2, and many others helped sort this out while documenting the problems in this (currently 25 page) thread: https://www.subaruoutback.org/forums...s-sensors.html. Up until now however, no one was sure if a complete do-it-yourself process would work for the sensors that Tire Rack used. The main solutions discovered this far were to move stock sensors onto new wheels or to buy clonable sensors and clone the stock sensor IDs onto the new sensors. But these solutions required at least one visit to a tire shop and often resulted in problems as documented in the thread. Many tire shops had trouble programming the ECU to recognize new sensors and dealers were charging up to $150 to do the programming. This was all unacceptable to me. I wanted to buy new wheels, bolt them on, and fix the TPMS myself. Here's how I did it.

Tools & Parts:
  • Wheels from Tire Rack with TPMS sensors installed for a 2018 or 2019 Outback. The invoice lists the sensors as, P/N S202 320602 "SCHRDR 433 MHZ G2 RBR V. SENSOR RUBBER VALVE PRE-INSTALLED"
  • Autel MaxiTPMS TS508 tool.
  • Various hand tools and sockets. Including a torque wrench.

Procedure:
Believe it or not, everything went smoothly, at least as far as TPMS is concerned.

Step 1: I bought a new TS508 from Tire Rack. I confirmed that it could read the stock sensors on the car to ensure it had a chance to work, then updated all the software on the tool using the Autel Maxi PC Suite software I downloaded from their site. (Side note, this software worked much better than the old software for my TS 401 tool which always had a COM port conflict on my PC requiring me to monkey around in Device Manager to disable an existing device on COM4 before it could recognize the 401 was connected. I had no such problems with the 508 and new software.)

The values updated were:
  • Sys from V1.19 --> V1.70
  • HW V1.00
  • Sens from V5.42 --> V5.53
  • Vehicle from V1.41 --> V1.53

Step 2: Swap the old wheels for the new ones. I installed the lugs by hand and torqued them appropriately with a torque wrench.

Step 3: Just to check, I selected 2018 Outback from the Basic menu and read the values of the new sensors to ensure they worked.
https://i.imgur.com/GpGNUb7.jpg

https://i.imgur.com/4jL79bA.jpg

https://i.imgur.com/MlE47aD.jpg

Step 4: Using the advanced menu, I selected Position Relearn and OBD Relearn, again for a 2018 Outback. Following the instructions on the screen I elected to delete previous readings. The tool had me rescan the four wheels in order, then connect to the OBD 2 port, then turn on the ignition (2 button presses on keyless without foot on the brake).

I was a bit nervous but the system never even blinked.

https://i.imgur.com/5QB5BPq.jpg

https://i.imgur.com/nEdNc51.jpg

https://i.imgur.com/AdtdaLQ.jpg

https://i.imgur.com/yebkMQb.jpg

https://i.imgur.com/bE2mkb4.jpg

Step 5: I turned off the ignition and disconnected the OBD cable. Started the car and no errors. TPMS screen showed no values, but there was no error. Following the instructions, I just drove the car. About 6 minutes and 2 miles later - boom, the 4 TPMS values appeared.

https://i.imgur.com/ML8PciY.jpg

https://i.imgur.com/zPkCzCj.jpg

Step 6: I went home and cleaned up my tools. When I went out later, for the first 30 seconds after starting there were no TPMS values, but within a few seconds after starting to move they appeared as normal. I compared the 4 values when I returned home to readings from the TS508 and the positions on the screen were correct.

So, as far as I can tell this was painless and everything worked perfectly. The latest version of the firmware for the Autel TS508 tool can read stock and aftermarket sensors and write the values to the ECU. So victory!

And, the TS508 is pretty reasonably priced: I got mine for $275 + tax at Tire Rack. They also make a kit that comes with 8 programmable (clonable) sensors (4 x 315 MHz, 4 x 433 MHz) for $320.

In the end, the new TS508 cost me less than the old Autel TS401 and the ATEQ Quickset I used to do this on my old 2016. So overall I'm thrilled. No tire shops or dealers for me.

Good luck if you're taking on a similar project.

Brucey 11-10-2018 06:58 PM

Thank you so much for this info.

I mentioned you in the sticky thread.

ShanMan14 11-10-2018 07:32 PM

Great write up, this will help a lot of people!

lfdal 11-11-2018 09:16 AM

I'll be looking forward to trying this out. I ordered the TS508 last night from TireRack. It's scheduled to show up Tuesday. Just for the heck of it I went to Autel's site then downloaded and installed their software. Figured I was cooked if there was a problem with that, but it went fine, so I should be all ready when the unit shows up. Thanks again for doing all the grunt work and posting the details.

Rub 11-11-2018 09:37 AM

@Grumpy - Your Man card is fully valid.

GeoffD 11-11-2018 11:35 AM

If you can get a tire shop to activate the TPMS senders and read the four serial numbers, you can do the same thing with an ATEQ TPMS QuickSet for $120.00 (Tire Rack price). You're only ever going to do the activate and read functions once assuming you save away the old serial numbers and back it up so you don't lose them.



I presume you can also buy senders where you can clone the old four serial numbers for your winter tires. I wasn't aware that was possible when I put together my winter wheel/snow tire setup in 2015.

GrumpySquatch 11-11-2018 09:45 PM

Quote:

Originally Posted by GeoffD (Post 5727937)
If you can get a tire shop to activate the TPMS senders and read the four serial numbers, you can do the same thing with an ATEQ TPMS QuickSet for $120.00 (Tire Rack price). You're only ever going to do the activate and read functions once assuming you save away the old serial numbers and back it up so you don't lose them.

I presume you can also buy senders where you can clone the old four serial numbers for your winter tires. I wasn't aware that was possible when I put together my winter wheel/snow tire setup in 2015.

Have you actually confirmed this on a 2018 or 2019 vehicle? Because I own an ATEQ Quickset and I had no success. The ATEQ coverage chart published as recently as August also indicates that the firmware doesn't support beyond 2017. See https://www.ateq-tpms.com/wp-content...2018-FINAL.pdf. We all agree that the ATEQ worked on earlier Gen 5 vehicles, including my 2016, but it doesn't appear that ATEQ will update the Quickset firmware to work with the new 2018/2019 systems until at least early 2019, hence all of our frustration.

DrCloud 11-12-2018 11:41 AM

In another thread, it was suggested that it might be possible to fool your programming device into working on an '18 OB by telling the device that you've got a '17 or '18 Impreza. Apparently, some of these devices have the Imprezas listed in their coverage chart but not '18 (or '19) OBs. But the Impreza setting works, for some, at least.


Alternatively, the people at my Discount Tire shop told me they'd reprogram the car twice a year for free, because I bought winter tires (with the hazard warranty) from them. Haven't tried it yet, but I'm cautiously optimistic (and, unless they've got a new device, it will test the Impreza theory.) HPH

lfdal 11-13-2018 11:56 AM

1 Attachment(s)
I don't think this is entirely off topic but its' an observation about the TPMS system that makes me wonder about how well it works.

I put my snow tires on yesterday afternoon, then had to make about an 8-mile round trip drive, a lot of it in the 35-45 mph range. This is typically the same drive I use to have my BMWs relearn new sensors after I make my seasonal change-over.

Anyway, when I selected the TPMS screen I could see the sensors were orange, with no data. That made perfect sense, but I never got a dash light indicating a TPMS problem. My previous Subaru's made the light come on while I was waiting to get my sensors reprogrammed.

I received my Autel 508 this morning and will be trying it later today. Initial impression is that it's a quality unit.

When I updated the unit it went flawlessly, it looks like they've made a version release since GrumpySquatch received his unit. I did notice one discrepancy and was wondering if maybe a typo "Sys from V1.19 --> V1.70" My system shows at V1.2

Just a follow-on edit, it worked and worked perfectly the first time. I ever meet you in person GrumpySquatch, the beer is on me.

martin_j001 11-13-2018 01:03 PM

I think I need this tool...


All times are GMT -4. The time now is 10:30 AM.

Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.

vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright 2009-2010 SubaruOutback.org. All Rights Reserved.

 
For the best viewing experience please update your browser to Google Chrome