2007 Outback Wagon - radio controls freeze - Subaru Outback - Subaru Outback Forums
 
LinkBack Thread Tools Rate Thread
post #1 of 9 (permalink) Old 03-22-2012, 10:54 AM Thread Starter
Registered User
 
Join Date: Mar 2012
Posts: 1
Feedback Score: 0 reviews
Post 2007 Outback Wagon - radio controls freeze

Have a 2007 Outbak Wagon with radio controls that freeze for no reason. It freezes and fixes itself randomly. What I mean by freeze is: can't change radio station with preset/scan/search buttons, can't change from am to fm to cd or aux, volume doesn't work. The only function that does work is the power button. Turning the radio off then on doesn't fix the problem.

I appreciate any feedback from someone who's had the same issue or can recommend a fix.

Thanks.

davidskleinman is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 03-22-2012, 11:33 AM
Registered User
 
Join Date: Mar 2012
Posts: 2
Feedback Score: 0 reviews
I have a 2008 and saw this happen for the first time the other day. Weird. Shut the car off and it went back to normal.

kelvinator60 is offline  
post #3 of 9 (permalink) Old 03-22-2012, 05:10 PM
Registered User
 
Join Date: Jun 2006
Location: Eastern ON Canada
Car: 07 OBW 2.5i D-4AT
Posts: 15,693
Feedback Score: 11 reviews
Is this by any chance with the premium radio with 6-CD changer and automatic heater/AC controls?

If so, there's a problem that causes the controls to freeze -- bad solder joints on a printed circuit board in the radio. There are posts here about it, including at least one where a member indicates what was found on the board and how it was fixed.

If it's not the premium system then, as far as I know, it's not something I recall being reported here before. But the intermittent nature would also suggest poor contacts -- possibly bad solder joints, or a loose/contaminated connector contact.

Let us know if it's the premium radio and we'll go from there, or do some searching with the search function -- the other posts should come up.
plain OM is offline  
post #4 of 9 (permalink) Old 03-22-2012, 09:08 PM
Registered User
 
Join Date: Jan 2008
Location: York ,PA.
Car: 2013 2.5 CVT Limited Outback Graphite Grey
Posts: 41
Feedback Score: 0 reviews
I have a 08 with 6 disc auto ac controls and it sounds like I may have the same issue but my issue only occurs when it is cold out, everything lights up cd will change discs but have no sound.drive for 5 or 10 min sound comes back and unit operates as it should till it gets cold......happens like clock work.i asked dealer about it and they have not dealt with this before, I asked about a rebuilt unit but was told they only deal with new ones under warranty, I asked for a ball park price for a replacement ... $700.00 ?? and was told at least that much.
Thankfully Winter was super mild this year so it does not happen often but will have to get this addressed before it gets cold again.

Rick
WINGED V is offline  
post #5 of 9 (permalink) Old 03-23-2012, 07:21 AM
Registered User
 
Join Date: Jun 2006
Location: Eastern ON Canada
Car: 07 OBW 2.5i D-4AT
Posts: 15,693
Feedback Score: 11 reviews
Here's one of the earlier threads that has more details about the solder problem: https://www.subaruoutback.org/forums/...ting-prob.html
plain OM is offline  
post #6 of 9 (permalink) Old 03-23-2012, 07:44 AM
Registered User
 
Join Date: Aug 2009
Location: Northern West Virginia
Car: 2009 2.5i, H4, Auto.
Posts: 842
Feedback Score: 0 reviews
I've go the base stereo and I have had this happen to me once. Some of the lights stop working, volume, radio control, media selector all stop working. The only thing that keeps working is the CD eject button. YOU could eject the disc and load a new one and it would start playing that disc, but you couldn't go back to the radio.

I've only had that happen to me once, so I haven't been too concerned about it.
Startiger is offline  
post #7 of 9 (permalink) Old 03-23-2012, 08:48 AM
Registered User
 
Join Date: Mar 2012
Posts: 2
Feedback Score: 0 reviews
Quote:
Originally Posted by Startiger View Post
I've go the base stereo and I have had this happen to me once. Some of the lights stop working, volume, radio control, media selector all stop working. The only thing that keeps working is the CD eject button. YOU could eject the disc and load a new one and it would start playing that disc, but you couldn't go back to the radio.

I've only had that happen to me once, so I haven't been too concerned about it.
This is my exact experience. Not a premium stereo just basic and it has only happened once so far. Last week, spring day, windows open. Who knows?
kelvinator60 is offline  
post #8 of 9 (permalink) Old 12-04-2012, 11:08 AM
Registered User
 
Join Date: Dec 2012
Posts: 2
Feedback Score: 0 reviews
I have a 2006 Outback with the 6CD changer. Last week all controls on the radio and HVAC froze at their existing settings and could not be changed. Turning the car off/on only brought control back for the audio volume but nothing else.

I read in different thread about Outback HVAC issues like this and that someone "found that light pressure on the front panel in the vicinity of the "3" button made it come back on."

I tried the same thing - pressure below the "3" button. It worked. I laughed my way home.

Clearly there is a bad connection behind that spot and other threads go into the details of repairing it for real. But try this temporary solution until you have time to pull things apart.
bikermike3 is offline  
post #9 of 9 (permalink) Old 11-10-2013, 08:22 PM
Registered User
 
Join Date: Nov 2013
Posts: 2
Feedback Score: 0 reviews
The #3 button trick worked for me!

Thanks, BikerMike3! That trick with the #3 button fixed my radio. Love the simple solutions.
KellyMpls is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Subaru Outback - Subaru Outback Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Rate This Thread
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome