Subaru Outback - Subaru Outback Forums - Reply to Topic
Thread: '17 Outback Electrical Issues - EyeSight Goes Blind, and takes everything with it Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 
   

Register Now



In order to be able to post messages on the Subaru Outback - Subaru Outback Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options
Rate Thread
If you like, you can add a score for this thread.

  Topic Review (Newest First)
04-28-2019 09:58 PM
FirestoneOutback
Code P2005 Showed Up

Hi all,

Following up on the exciting CEL fun. So, after posting this about two weeks ago, it seems things were cleaned up with the simple gas cap trip. Well, related or not, another CEL appeared today. Was able to get this one checked out in time.

Pulled P2005 "Intake manifold runner control stuck open bank 2."

So... umm... off to the shop I go or is there a better fix for this one?

Thanks!
04-21-2019 08:51 PM
ronemus There is a battery charging TSB for a '17 - I had it done on mine. Subaru has performed TSB repairs out of warranty, but the dealer has to get authorization; it's not pre-authorized the way warranty repairs are.
04-20-2019 09:35 PM
skipw
Quote:
Originally Posted by ronemus View Post
Have they done the battery charging update? The original charging scheme would leave the battery weak since it only fully charged the battery under braking.
Does that TSB apply to '17s? I don't remember for sure, but think it doesn't.

Quote:
The update is free under a TSB.
Only if the car is still under warranty. It's not expensive, though.

Quote:
The first step in testing a battery is to charge it, so it doesn't measure the state of charge as received.

<image link broken>
04-20-2019 08:55 PM
ronemus Have they done the battery charging update? The original charging scheme would leave the battery weak since it only fully charged the battery under braking. The update is free under a TSB. The first step in testing a battery is to charge it, so it doesn't measure the state of charge as received.
04-20-2019 11:41 AM
FirestoneOutback Hi all,

Thanks for the excellent responses on this. I learned a lot, and your team is greatly appreciated!

Took the car in for an oil change and the latest recall reprogramming, and they looked at the CEL issue. They couldn't find any active codes to pull, so the running theory is that it was a loose gas cap issue. I'll be making use to double-double-double check that cap every time. You'd think that Subaru could have a "loose gas cap" light on the dash instead of a "OMG YOU CAR IS DYING RIGHT NOW AND YOU WILL TOO BECAUSE REASONS YOU CAN'T FATHOM!" or something like that.

They also tested the 6-month old battery, and it was good to go.

You all rock! Thanks again for the help.
04-19-2019 06:21 AM
Zedhead Or, possibly another defective battery?
04-17-2019 12:21 PM
Danver Since all was good for the 6,000 miles after the battery was replaced there is a chance this is something completely different and possibly unrelated. Many of the things that will trip the check engine light will also shut down Eyesight and light up all kinds of lights on the dash. First thing to do is check the codes as has been mentioned. Might just be something simple.
04-17-2019 10:57 AM
dmac3 I've seen it, unfortunately, in my 2017 Legacy 2.5 Premium with Eyesight, which uses the same components as the Outback. The dealer replaced many parts, mostly having something to do with the brakes and communication between modules (or something like that). After about ten months of this happening often and the dealer and Subaru Reps from Corporate apparently not able to fix the problem, Subaru bought the car back.


I bought that Legacy in late summer 2016. Periodically, I come across someone who sounds like they are having similar problems. But, without the diagnosis, I'd never know. This situation seems to be few and far between on these vehicles. Pain in the butt if it happens to you, though.


From your pictures, I think mine had every light lit on the dash. Your's looks less so. What are some of the codes. I did write about this back at the time over on the Legacy forum.


On certain occasions, the brake pedal would go right to the floor on my new car. That Legacy was not a fun car to drive and spent almost half it's life at the dealer.
04-16-2019 06:18 PM
skipw How long ago did they replace the battery? Do you have a list of the codes they got?

What are the codes this time? Most auto parts stores have a code reader you can borrow, and will help you use it if needed.

Read and record all the codes, and descriptions, if any, that the reader provides . List them here - accurately - especially the alphanumeric codes. There are some guys who follow these forums who are pretty good at understanding what they are telling you.

All those auxiliary systems shutting down when the CEL turns on is how the system is designed to operate. I bet the cruise control doesn't work, either. You are pretty much forced to deal with the cause of the CEL; in the old days, just sticking a piece of tape over the light, or removing the bulb, "fixed" it, or seemed to, regardless of what the problem was. Can't do that any more.
04-16-2019 05:59 PM
FirestoneOutback
'17 Outback Electrical Issues - EyeSight Goes Blind, and takes everything with it

Hi Forum, hope you are all having a great day!

I'm desperately searching for some help with my 2017 Outback 2.5i Limited w/ Eyesight. This car has had way too many issues since I bought it new, and this one has been on- and off- again for over two years.

Basically, while driving, the EyeSight will suddenly disengage and the Check Engine light along with RAB, lane keep, collision prevention warning lights all turn on. Cruise control and x-mode are completely disabled as well. Basically, anything useful other than the engine. This condition will persist for several days, and then magically clear up. However, there is no warning about when or why this is happening.

The dealer has looked at this on several occasions. When they pull the error codes, it is literally dozens of codes all related to the electrical system. About 6,000 miles ago they settled on a defective battery, replaced it, and everything seemed fine... until two days ago when this happened again.

Has anyone seen this or have any insights as to what the heck is going on?

Thank you in advance for anything you can do to help!

FirestoneOutback

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome