Subaru Outback Forums banner

Search results

1-13 of 13 Results
Advanced Search
  1. What did you do with your 3rd Gen Outback today?

    Gen 3: 2005-2009
    was getting a lot of vibration at anything over about 30 mph. felt like it was coming from the front L so I changed out the axle and ball joint. still there. dealership said I needed a new drive shaft. I had purchased 2 axles, but hadn't put the other one in the R side yet. almost bought a new...
  2. Need help with my new purchase

    New Member/User? Look Here!
    saw an OB in a parking lot with 225/65r17. looked great. didn't look like there was a lift. The tires were Toyo Open Country. I really like the BFG AT2, but they are a bit pricey. I have 225/60R17 Geolander AT-S on my 2005, no lift. I drive a LOT of highway miles and have been very happy with them.
  3. Whirring noise under load

    Gen 3: 2005-2009
    So for those of you playing at home, the correct answer was the throttle body Inter cooler hose. I took it to the dealer and now there is no more noise. Now I just need to decide if I should roll the dice on a junk yard main drive shaft or replace the u joints on mine. Then I’ll be ready for ski...
  4. Whirring noise under load

    Gen 3: 2005-2009
    for what it's worth, the turbo was replaced with a factory unit at 155,000 miles
  5. Whirring noise under load

    Gen 3: 2005-2009
    The turbo was my first thought, but should I be able to hear the turbo spin up in park? When I push the accelerator in park, I don't get any of the whirring noise. The only time I hear the noise is accelerating while driving. If I accelerate super slow, even up to 4-5k rpm, I don't get the noise.
  6. Whirring noise under load

    Gen 3: 2005-2009
    The speed doesn't seem to have any relation to the noise. as long as the load is minimal, there is no whirring. I get a whir accelerating from a stop and also if I accelerate while driving. I also don't get any noise in Park/Neutral by pressing the accelerator even over 6k RPMs...
  7. If you have never cleaned your MAF sensor, do it. You'll thank me later.

    Gen 3: 2005-2009
    you're getting 24mpg? I'm lucky to get 19-20!
  8. Whirring noise under load

    Gen 3: 2005-2009
    '05 OBXT. 230k miles. I am getting a whirring noise when I accelerate at any moderate to aggressive rate. seems like its more on the Left (drivers) side. Havent stapped myself to the hood with my stethascope yet (I'm a nurse so I have a few). If I accelerate slowly or downshift with minimal...
  9. Timelapse Video of my 2.5 Struggling up Carson Pass

    Gen 5: 2015-2019
    Nice, glad to see the 2.5 does fine. I patrol up at powder mountain in utah and I'm glad I have the XT. steepest state road in utah. pray for snow!
  10. Replacing valve cover gaskets on a 05 xt?

    Gen 3: 2005-2009
    I'll have to take a photo of the two vacuum hoses under the IC. They are only about 1/4" in diameter. All the stuff re: the PCV valve seems to be at least 1 1/2" hose. The post about the plastic piece above with the PCV valve isn't what I replaced. The piece I replaced is the one that the hoses...
  11. Replacing valve cover gaskets on a 05 xt?

    Gen 3: 2005-2009
    I actually did replace the entire plastic piece as well. It cracked when I tried to pull the hose off. Just can't figure out what the little vacuum hoses are and where they attach.
  12. Replacing valve cover gaskets on a 05 xt?

    Gen 3: 2005-2009
    Just did mine, didn't lift the engine, the only problem I had was the hoses that attached to the valve cover were so brittle, I didn't know they were hoses. I thought they may have been hard pipes! Once they cracked off (on a Saturday) I couldn't find what they were or any part numbers so I just...
  13. Check engine light; car shuddering

    Problems & Maintenance
    I know this an old thread, but I just ran into the same problem. I was a little less than 1/4 tank so I stopped for a fill up. 91 octane (highest they have in Utah). Drove 3-4 miles and stopped. After I started it up again a couple hours later, it started shuddering bad, check engine light...
1-13 of 13 Results
Top