Subaru Outback Forums banner
  • Hey everyone! Enter your ride HERE to be a part of September's Outback of the Month Challenge!
check engine light
1-7 of 7 Results
  1. Gen 4: 2010-2014
    Wife had the Outback (sorry.. haha..) but she called me on the phone saying that: Engine light was on (solid) "slipping car" light was on (solid) Cruise control light was blinking "BRAKE" light was blinking (.. and from what I can see the above stuff is fairly common...) but (when I had the...
  2. Problems & DIY Maintenance
    Hey there. I recently purchased a 2012 Subaru Forester from a dealer 3 weeks ago with 96000 miles on it. All was well until yesterday I sped up to pass someone on the highway and the check engine light, cruise control light and off road light all came on at the same time. Plugged in my OBD2...
  3. Problems & DIY Maintenance
    Hey guys, so I have a 16 Outback 2.5i limited. Last night I Unfortunately got hit by a 2' wall of water in a Flash flood coming down a street I was on. I wasn't able to avoid it and thankfully I was able to get through it and get myself to higher ground. The 3 other cars around me got swept...
  4. Gen 3: 2005-2009
    Figured I might as well start a thread on this one too if I'm here about the swaylinks. Two days before I took the car in to the dealer for them to tell me I should replace my whole new aftermarket sway bar with a stock one to fix my noise 🙄 I also picked up a CEL. Of course they wouldn't...
  5. Engine & Drivetrain
    Hi everyone I took my 2003 outback into my usual mechanic for P0420 codes and he replaced the Catalytic Converter. Check Engine light came back on only two days after, so I ran the codes and got P0420 again. I cleared them and chalked it up to the new CC needing a few days. I am not noticing...
  6. Problems & DIY Maintenance
    I have a 2004 Outback Legacy wagon with two fault codes creating a check engine light. The codes are P0400 (EGR A Flow) and P0031 (HO2S Heater Control Circuit Low (BANK 1 Sensor1)). I've been told to not worry about them -- the first time I took it in they cleared the codes for me and they came...
  7. Problems & DIY Maintenance
    Even after replacing the catalytic converter and 02 sensors, the problem returned within 3 months. The CEL is on whenever the car is running. If I disconnect the battery to reset it, the CEL comes back on somewhere between 75 and 90 miles of driving. Odd symptoms: when key is in “On” position...
1-7 of 7 Results
Top