Subaru Outback Forums banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-8 of 8 Results
  1. Gen 2: 2000-2004
    I've recently swapped an EZ30D (first-gen, alloy manifold) from an Outback into my 2003 Forester, and have just this P0154 code lingering, despite replacing both of the O2 sensors since the previous ones had dud heaters (P0031 & P0051 were the only codes before I pulled the engine). Here are...
  2. Problems & DIY Maintenance
    Hi, I'm working on a 2002 Subaru Outback limited sedan. I had it throwing P0420 for a long time, I disconnected the battery for a week while looking for a replacement for it. Once the new battery was in the codes were obviously cleared so I ran it around a little and then the light came back on...
  3. Gen 3: 2005-2009
    Hi Everyone, I'm replacing the upstream and downstream O2 sensors on my 2008 Outback 2.5L (Non-Turbo). Purchased Bosch parts from a reputable auto parts distributor. However, when we went to install, the sensor connector was incompatible with the wiring harness in the car! Below is a picture...
  4. Problems & DIY Maintenance
    Hey folks! RE: my 2013 Subaru Outback P0031 Code (O2 sensor) Diagnosis Mechanic recommends replacing all four sensors since I'm at 150k miles and he expects the others to fail soon enough. Is that a good $500 investment in your estimation? Here's the quote I received (incl. oil change, excl...
  5. Gen 5: 2015-2019
    2017 Outback Limited 3.6R - 45,000 miles The Check Engine Light is Not ON Using my OBD-2 analyzer, I recently got: P013D - O2 Sensor slow response - Lean to Rich Bank 2 Sensor 2 P1604 - No description - I don't know what this is I cleared the codes but these came up again after the next time I...
  6. Problems & DIY Maintenance
    I have a 2005 Outback, approx 130K miles. Have an odd problem, in that I've had to replace the upstream O2 sensor twice in about 2.5 - 3 years, and I think it's going bad again approx 18 mos. after last change. Ran fine until recently Is there something that could be causing the O2 sensor to...
  7. Performance Parts & Accessories
    I've been having a lot of issues with my 2012 Outback 2.5 lately. Rough idle (has stalled a couple times from idle), real crappy gas mileage, P2096, a ton of rattling (probably the heat shields though), and rotten eggish smell. I've been told by several people it sounds like a catalytic...
  8. Gen 3: 2005-2009
    I’m sure I’m asking a question that is already out there but I’m not finding it. I have an 05 base model California exhaust. I have a P0420 code that I’m going to replace the O2 sensors first before I replace the catalytic coverts to see if that corrects the CEL. Under the car I have the 2 up...
1-8 of 8 Results
Top