Subaru Outback Forums banner
  • Hey everyone! Enter your ride HERE to be a part of October's Outback of the Month Challenge!
1 - 10 of 10 Posts

·
Registered
03 outback
Joined
·
26 Posts
Discussion Starter · #1 ·
My 03 2.5 idles real rough. I cleaned throttle body and put plugs in it. It doesn't have cel on i plugged in scanner and it says 0068 map maf sensor pending. Has anyone else had this problem and how did you fix it. The car runs great. Just wont idle
 

·
Registered
2003 OBW 2.5L 4EAT
Joined
·
861 Posts
What rpm is it idling at? Should be around 750 rpm.
 

·
Premium Member
01 VDC, 05 R Sedan, 06 BAJA EJ257
Joined
·
16,269 Posts
Can your scanner read the live data? If so, what does it show the MAP sensor data at with the key on, engine not running; then with the engine idling? Compare the key on not running with the current barometric pressure of your area and post back.

It could be a bad MAP or vacuum leak. Have you checked the fuel filter?
 

·
Registered
03 outback
Joined
·
26 Posts
Discussion Starter · #4 ·
I replaced fuel filter. Its barely idling. 250. -500 rpm when warm. Will check pressure and post
 

·
Registered
03 outback
Joined
·
26 Posts
Discussion Starter · #5 ·
Checked map pressure. Its reading 29.2 while actually is 30.12 outside. When i started it went to 18.6. Does this seem right. I also have p0068 map maf cel
 

·
Premium Member
01 VDC, 05 R Sedan, 06 BAJA EJ257
Joined
·
16,269 Posts
Checked map pressure. Its reading 29.2 while actually is 30.12 outside. When i started it went to 18.6. Does this seem right. I also have p0068 map maf cel
That's good. The reading prior to start is close enough to actual barometric pressure. The 18.6 means the engine is pulling 9.5 in vacuum idling, which is also normal.

The problem is somewhere else.

Look at the data for the throttle position sensor, key on engine off. 5% is closed, 85% is full open. Press on the pedal slow and the value should change incremental with the pedal position. If there is any deviation in the closed value or WOT (wide open throttle), its a fault in the TPS. When the TPS sends higher values than where it actually is, the ECM is adjusting the IACV according to the TPS value, closing it which will ultimately reduce air flow into the engine and lower the idle. It will run fine at higher rpm because the throttle plate is open allowing for air flow.

If the TPS checks out good, check the ground lug on the intake and make sure its clean and w/o corrosion. It is a group of black wires bolted to the intake with a 10mm hexhead screw just to the passenger side of the throttle. There are also 3 ground lugs on the firewall, center where the transmission torque arm bolts to it.

Let us know what you find.
 

·
Registered
03 outback
Joined
·
26 Posts
Discussion Starter · #7 ·
bought a new throttle position sensor and set it at 5.0 and now i got new problems, it seems to either idle at 2000 or not at all, i also get buzzing sound which i think is coming from idle air control motor, when it wont idle i unplugged idle air and it runs just the same is the idle air buzzing normal? i notice when setting tps at 5.0 when i went to far it would start to buzz
 

·
Premium Member
01 VDC, 05 R Sedan, 06 BAJA EJ257
Joined
·
16,269 Posts
The throttle position sensor may be holding the throttle plate open. The throttle is open already, so disconnecting the IACV allows for the engine to operate because it is able to pull air in past the throttle plate. Or you have something disconnected and its creating a vacuum leak.

Just because I thought of it, and it may come up somewhere, it may be good for readers to know that an IACV valve opens under throttle, more so than at idle. The computer does this so it can control the idle down. When you let off the throttle, the ECM reduces the IACV slowly to normal idle. In this way, the idle doesn't drop too fast and flood the engine or cause a stumble. All management actuators react better to control the engine operation, i.e. air, fuel, fire.
 

·
Registered
03 outback
Joined
·
26 Posts
Discussion Starter · #9 ·
I do get a uptick When I rev it. It revs to 3000 I ley off the gas and it lowers rpm and than revs back up and then goes down
 

·
Registered
03 outback
Joined
·
26 Posts
Discussion Starter · #10 ·
And it seems to either idle at 2000 or 400 no happy médium. I hit the gas in park and it will idle at 2000 Drive it around alittle and it drops to 400. Put in park and it stays at 400. Hit the gas and it starts to idle at 2000 again
 
1 - 10 of 10 Posts
Top