Subaru Outback Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
51 Posts
Discussion Starter #1
As you all know my car kept over heating... I could drive it for a little then it would start to over heat again... Well they took it in and I got it back today.... The guy who sells them where I live refuses to work on twin cams because there a pain in the butt. He said he would have his friend 100 miles up in the mountain with his two diesel mechanic sons to work on it. The guy hauled it up and drove it back down when he was done which was today. He said he took the heads off went to his friend then and his friend judges if the heads are good or not. He said this one is good this one is bad... He replaced the 1 head. All head gaskets. Cam seals and crank shaft seals. Timing and water pump and thermostat. The car runs great but feels like it lost power? Lol maybe its just me but it could be because I drove a z24 cavalier as a rental while car was in shop...also they said to drive car easy for 500 miles... One other question... If they replaced one head but the other was fine...does that mean the other will go out sometime soon?

Thank you all... I love my car hope I have no more issues... He did that all for a favor and for 800$
 

·
Registered
OBW H6 VDC, Tribeca, XT6
Joined
·
12,391 Posts
yep, drive it.

probably junked a good head though. it happens but i've never seen or really heard of a bad non-turbo EJ head.

they always have high and low spots but nothing that doesn't come out with some standard resurfacing.

unless of course it was severely overheated, but at that point i wouldn't consider the block worth keeping.
 

·
Registered
Joined
·
51 Posts
Discussion Starter #6
when I got car back I saw it was leaking oil I thought it could have been from oil pan gasket. like I might have to replace it. not that much to do... kept seeing oil spots all over the parking lot at my house. I finally looked under after 2 days of having the car and having the egr valve **** eyed and having that fixed to... but the oil is coming out of the driver side cam... last time I checked you don't luburcate belts with oil. they said the did the cam seals to. I'm at a wtf moment.
 

·
Premium Member
2001 VDC/SC One of a Kind
Joined
·
14,320 Posts
They used aftermarket cheap seals that don't fit or they aren't installed proper. If they aren't Beck Arnley or from Subaru parts (Beck Arnley) they leak. The correct seals are brown.
 
1 - 7 of 7 Posts
Top