Subaru Outback Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter #1
A week ago the check engine light came on and the cruise control indicator started flashing. It ran rough for a bit and then was OK.

Later I checked and I got these OBD codes:

P0016 - crankshaft position cam shaft position correlation bank 1 sensor A

P0018 - crankshaft position cam shaft position correlation bank 2 sensor A

P0021 - camshaft position timing over advance OR system performance bank 2

I went to start it again a few days ago (I only drive it about once a week) and it would start but then quickly stall - not drivable.

Has anyone had experience with these codes and this situation and what ended up as the problem(s)?

2006 outback 3.0L with about 205K miles.

Thanks!
 

·
Registered
1999 30th Anniversary Legacy Outback DOHC 2.5L 4EAT, 2008 Impreza WRX 2.5L 5MT, 2008 Impreza Wagon 2.5L 4EAT
Joined
·
1,224 Posts
A bad crankshaft position sensor won't let the car run. Probably it needs to be replaced. I don't have a 3.0L engine so don't know where they live
 

·
Registered
03 H6 OBW & 06 WRX Sportwagon
Joined
·
17,689 Posts
oil level OK? has the car been maintained well?


how old is the battery?

did the codes come back immediately after clearing the ECU? exact same codes?
 

·
Registered
Joined
·
36 Posts
Discussion Starter #5
I had it towed to my shop. Their diagnostic test showed a "faulty MAF sensor".

The labor was "Air Flow Meter - Remove and Replace."

The part was "New Air Mass Sensor"

The car is running fine again.

The plan is to clear the current codes and see if problem returns.

If the problem recurs, I'll be sure to update my post. If this resolves the problem, I'll try to remember to update.

This is a great forum!

Thanks!
 

·
On the Super Mod Squad
2002 3.0 VDC Wag + 2018 2.5 Leg Ltd
Joined
·
26,302 Posts
by towed, I hope you mean "flat bedded" (the only subaru way).
 
1 - 8 of 8 Posts
Top