Subaru Outback Forums banner

1 - 20 of 22 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
Hello i have a legacy 2007 Ez30 with a misfire problem.
Not always but when starting the enigine it will misfire for a second or less.
No misfires when driving only when start cold or warm.

One time i got a pending p0174 code with the tourqe app but there is no cel light on.

Maf sensor was dirty as **** so i clean it up and later replaced it.
Lambda sensor is replaced but the problem is still there.

Now i need your help to solve this annoying problem , what is the most common problem on these engines?
 

·
On the Super Mod Squad
2002 3.0 VDC Wag + 2018 2.5 Leg Ltd
Joined
·
26,308 Posts
lambda = the front o2 = front air fuel sensor. (lambda is not a typical term used here)

age / type of spark plugs? (this car takes NGK iridium,...and may not like others,...or they will fail quick).

_____

do you have a windows laptop to get some logs with free rom raider?
 

·
Registered
Joined
·
30 Posts
Discussion Starter #3
Sorry i live in Sweden and here we call it lambda sensor.
The sparkplug was replaced at 10500 km (now at 17000km) .
Dont know what brand or type they are.
 

·
On the Super Mod Squad
2002 3.0 VDC Wag + 2018 2.5 Leg Ltd
Joined
·
26,308 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #10
How long does your H6 engine crank before start?
2 seconds or instantly?
Yesterday when driving for about an hour i turned of he car for about 15 minutes and when i crank the engine it cranks twice the time as usual.
 

·
Registered
03 H6 OBW & 06 WRX Sportwagon
Joined
·
17,704 Posts
older soobs sometimes have fuel leaks at clamps under the hood, worse in cold weather, - maybe you're losing fuel pressure in the rails? tighten every screw clamp you can find on the fuel lines.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #14
Hmm might this have something related.
When my gastank is almost empty it start to missfire even more when starting the car?
 

·
Registered
03 H6 OBW & 06 WRX Sportwagon
Joined
·
17,704 Posts
here, parts retailers will loan/rent tools - maybe measure your fuel pressure?
 

·
Master Caster
2005 XT, Mildly Modified...2006 XT Limited, Highly Modifed
Joined
·
16,144 Posts
here, parts retailers will loan/rent tools - maybe measure your fuel pressure?
100% second on that.

Low on fuel bad, and if you even noticed a change.
 

·
Master Caster
2005 XT, Mildly Modified...2006 XT Limited, Highly Modifed
Joined
·
16,144 Posts
How long does your H6 engine crank before start?
2 seconds or instantly?
Yesterday when driving for about an hour i turned of he car for about 15 minutes and when i crank the engine it cranks twice the time as usual.
This sounds more and more like fuel pressure. Turn on you key, but don't crank. Let the key on for 10-15 sec and then try. If it fires right up, my suggestion is there is a lack of fuel pressure. Waiting the 10-15sec will let the fuel pump duty cycle run at max until you are pressurized and then not issues.

There is also a common o-ring issue in the fuel pump assembly. More an issue with turbos, but still something worth investigation.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #18
Hello i still have the problem noone can find the reason of.
But some days ago i noticed i can replicate the misfire.
If i hold the gaspedal at full throttle it will stumble/misfire right at the starting moment.

Will this give any clues?
 

·
Registered
2010 Outback 3.6R 2014 Legacy 2.5i 2003 Legacy L special edition (retired to backup)
Joined
·
1,825 Posts
are you getting long crank after clearing codes? My 2010 Outback 3.6R did that when I cleared the p0420 codes, after that start it has been fine. check for vacuum leaks and or cracked hoses in the intake tract.
 
1 - 20 of 22 Posts
Top