Subaru Outback Forums banner
1 - 20 of 22 Posts

·
Registered
2015 2.5i Limited Carbide Gray
Joined
·
832 Posts
Discussion Starter · #1 ·
After a few requests I've got a few pics of my install. For those who haven't checked the '12 has a different harness for the radio than the '10 and '11. Ironically it's the same harness that Toyota has used since '87. It seems the BRZ isn't the only thing Subaru and Toyota have gotten together on!

On to the pics:





As you can see all of the other necessities work the same, the dash kit and antenna adapter, but the harness will need RCA's soldered on if you have a limited with the H/K. Feel free to email or PM me if you have any questions.
 

·
Registered
Joined
·
262 Posts
I put in a kenwood deck and my reception went down hill. How is yours? (yes the lead for the antenna amp is connected) It fades in and out though compared to the stock radio.
 

·
Registered
'11 Outback 2.5i CVT - '06 Forester X 5MT
Joined
·
1,765 Posts
Interesting the harness has changed, AGAIN!

I used the same harness from my 98 Impreza to my '05 Impreza to my '08 Legacy. I was hoping to move my oem amp from my '08 Legacy to the OB along with my XM, but saw they changed the harness and didn't feel like messing with splicing.

Nice install, I'm hoping to upgrade within the next year or so. A hitch is first on my list though...
 

·
Registered
2012 3.6R Limited
Joined
·
222 Posts
Okay, question time:

1) Did you end up connecting SWC? If so, what did you get to make the connection?

2) Do you need to splice in to the 28-pin connector for the amp turn-on?

3) It looks like that's a GPS. Where did you connect the speed sensor?

4) Did you have to make any changes to the Toyota harness? (I've read mixed posts on the blue/white lead needing to be changed out, cut, etc.)
 

·
Registered
2015 2.5i Limited Carbide Gray
Joined
·
832 Posts
Discussion Starter · #6 ·
AWD: Sadly I don't use the FM tuner. I've got Sirius and my wife both listen to that or the iPod in the console.

Totally: 1) I did use the SWC and got a 28 pin harness for the SWC and the amp turn on as well as the SWC wires. I got it from David. I used the ASWC and the Kenwood that I have doesn't support all of the phone features but I programmed it using the resistor like Axxess said. You can manually program it as well (which is what I did at first).
2) Yes, the amp turn on is in the 28 pin connector but I got one from David that had the amp turn on but it could just be tapped into. If David didn't have one of the 28 pin harnesses I would have just tapped into the OEM wiring.
3) The Kenwood's don't use a speed signal input like Pioneer's so I didn't have to worry with it. I would guess (and purely a guess) that there might a VSS wire in the 28 pin harness.
4) Yes I did have to move the blue wire in the Toyota harness. The antenna turn on is in the standard harness and does have to be moved from the 10 pin to the 6 pin harness. I can't remember what the location but I just plugged it in and matched it up the yellow/black wire in the OEM harness. Like you saw I used RCA's soldered to the speaker wires for input into the amp.

Feel free to post on here, PM or email me if you have any more questions or need any other information or pics.
 

·
Registered
2015 2.5i Limited Carbide Gray
Joined
·
832 Posts
Discussion Starter · #11 ·
Sorry!! I fixed it!

I had to use a matching brain for the Kenwood but I was able to use the OEM shark fin. I only had to notch the side of the case of the new tuner to get the antenna to plug in.
 

·
Registered
2015 2.5i Limited Carbide Gray
Joined
·
832 Posts
Discussion Starter · #12 ·
Do you have any pictures that aren't thumbnails? And maybe more that show the actual installation?
Let me know if there is anything in particular that you would want to see. I don't care to pull the radio and snap a few if I don't already have it.
 

·
Registered
2012 2.5i Premium CVT
Joined
·
921 Posts
lashlee, can you possibly provide a link to the wiring harness? I just prewired a "2012 Outback Premium..." harness I got from crutchfield and pulled the stereo out today. It was a totally different plug. All that time I spent soldering!

Thanks
 

·
Registered
2015 2.5i Limited Carbide Gray
Joined
·
832 Posts
Discussion Starter · #14 ·
Here is a link to the harness that I used: Metra Part # 70-1761 | Toyota wire harness | Metra Online

I haven't had a premium apart to verify that it's the same harness (though I would expect it to be). Make sure that you move the power antenna wire from the 10 pin harness to the 6 pin harness if it is the Toyota harness. I would stop by a specialty stereo shop in your area and see if they can't help you out. They should have a large selection of harness' and should be able to help you in your search. I don't like dealing with Crutchfield for the reason you stated (though they are usually good to help you out) but I did contact Metra and Scosche about the harness differences I found.
 

·
Registered
2012 2.5i Premium CVT
Joined
·
921 Posts
Here is a link to the harness that I used: Metra Part # 70-1761 | Toyota wire harness | Metra Online

I haven't had a premium apart to verify that it's the same harness (though I would expect it to be). Make sure that you move the power antenna wire from the 10 pin harness to the 6 pin harness if it is the Toyota harness. I would stop by a specialty stereo shop in your area and see if they can't help you out. They should have a large selection of harness' and should be able to help you in your search. I don't like dealing with Crutchfield for the reason you stated (though they are usually good to help you out) but I did contact Metra and Scosche about the harness differences I found.
Thanks. After getting a decent night's sleep it makes sense now. I need the 20 pin harness. Your answer to my other thread helped a lot too.
 

·
Registered
2015 2.5i Limited Carbide Gray
Joined
·
832 Posts
Discussion Starter · #16 ·
I'm glad to help! If you need anything else feel free to ask on here or PM or email me directly through here. Good luck with the install.
 

·
Registered
2015 2.5i Limited Carbide Gray
Joined
·
832 Posts
Discussion Starter · #17 ·
UPDATE:

I spent some time on the phone with Metra yesterday about the ASWC. They have new wiring information and I was able to get the steering wheel buttons to work with my Kenwood. The push to talk is now a mute button but the pick up and hang up now work!!

My wife is much happier now, which means I hear much less nagging!
 

·
Registered
2012 Silver Outback Premium 2.5 CVT
Joined
·
180 Posts
UPDATE:

I spent some time on the phone with Metra yesterday about the ASWC. They have new wiring information and I was able to get the steering wheel buttons to work with my Kenwood. The push to talk is now a mute button but the pick up and hang up now work!!

My wife is much happier now, which means I hear much less nagging!
Oh wow, how did that work? Got the same setup and would love to at least put two more buttons to work.
 

·
Registered
'11 outback 2.5i premium '12 impreza sport limited
Joined
·
3,814 Posts
i have the dnx-6980. i wish i would've gotten something else. soo hard to use compared to others. the radio reception sucks but just about all aftermarket does. i don't know how many i've had to pull up the full manual on pdf, the "manual" that comes with is completely useless. also very annoying when it freezes up, not frequent but very annoying.
 
1 - 20 of 22 Posts
Top