Subaru Outback Forums banner
1 - 7 of 7 Posts

·
Registered
2008 Outback XT 2.5 turbo
Joined
·
6 Posts
Discussion Starter · #1 ·
Hey y’all, I’ve been out of the Subaru gang since 2009 but I’m thrilled to say I just recently picked up a 2008 Outback XT! Unfortunately I bought it with an airbag light on figuring that it was something simple and I could fix it easily being that I’m a mechanic. Well I’m officially at my wits end with this airbag light. After doing some diagnostic with the big fancy scan tool, I’ve found that nothing SRS related on the passenger side works (occupancy detector, seatbelt pretensioner,seatbelt buckle,side curtain, passenger airbag on/off light)and all show a fault in the scan tool. In my years as a mechanic I’ve never seen anything like this. The scan tool can communicate with the module and clear the faults but they return immediately. I pulled up the carpet and spent about 2 hours checking continuity through the wires going from the module to the various components and all wires I’ve checked so far have been good. I’m at a complete loss and really hoping somebody on here has seen something similar to this in these cars. Thank y’all in advance for any insight!
 

·
Registered
2008 Outback XT 2.5 turbo
Joined
·
6 Posts
Discussion Starter · #4 ·
Thanks for the response cash, I replaced that whole dome light assembly 2 days ago ($100 for the part from dealer) because the airbag on/off light was really dim. Unfortunately, it didn’t resolve the issue.
 

·
On the Super Mod Squad
2002 3.0 VDC Wag + 2018 2.5 Leg Ltd
Joined
·
27,163 Posts

·
Premium Member
01 VDC, 05 R Sedan, 06 BAJA EJ257
Joined
·
16,464 Posts
Two things come to mind. Well, a lot of things come to mind, but related to this it would seem the car has been wrecked on the passenger side and the bags went off. Did you pull the headliner and check the curtain? Or, you have an open you haven't found yet for some reason. Those connectors don't come apart easily, so maybe someone prior to you has been in there. Could be someone spilled some liquid on the airbag module. The module sits under the center console, the reason I suggest someone spilled liquid on it. Have you been in there to check for corrosion? Signs of a spill? All kinds of things come with used cars, particularly extra supplies and leavings. See here and the postthat follow it: http://www.subaruoutback.org/forums/110-gen-2-2000-2004/58666-got-deal-outback-4.html#post614866
 

·
Registered
2008 Outback XT 2.5 turbo
Joined
·
6 Posts
Discussion Starter · #7 ·
Eagleeye, the codes I remember off hand are: C2, 26, 29. I’m having to work on this thing between customer cars so I can’t check right now. I had the 2000 outback sedan a while ago. I now have the 2008 outback xt 2.5 turbo with auto trans, also has leather and sport suspension

Cardoc, nothing shows indication of a crash or replaced parts, no tool marks on any bolts or connectors. Doesn’t look like anything has spilled because everything including the module is very clean other than normal dust. All the pins on the module are corrosion free.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top