Subaru Outback Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter #1
Hi there,

I have a 06 Outback LLBean and recently I started having a problem. When it happens, the check engine light is on and the green "cruise" light turns on and off by itself, and cruise control does not work. Cruise was not being used when it happened (I rarely use the cruise). After the car is off and sit for a while or over night, the problem is gone. This has happened three times within a few weeks and I decided it's time to bring it to the dealer (I have extended warranty). Just got a call from dealer and they said they can not pin point the problem with the error code and the car is normal at this point. They suggested trying an engine cleaning/oil change which may clean some sensor and I'll have to pay for the procedure. It did not make sense to me and I turned down the suggestion. They said they'll try to keep driving the car for the rest of the day and see if the problem can be reproduced. My guess is I'll get the car back with nothing done and will have the problem again sooner or later.

Any idea what may be causing the problem and how I should deal with the dealer in this case? I understand it may be an intermittent problem and hard to diagnose but the extended warranty seems useless in this case :(.
 

·
Registered
2013 OB Limited 3.6R
Joined
·
30 Posts
funny- I have the same problem on 05 llbean. My dealer suggested to change the catalytic converters after seeing a 420 error code. What error code do you have? You can get it checked at a Autozone for free. I had the CEL & cruise light flashing on a misfire before.
you can check this sticky for the OBD codes.
 

·
Premium Member
03 H6 OBW & 06 WRX Sportwagon
Joined
·
17,839 Posts
ask them for the DTC (the stored code or codes that they scanned) and post them here.

what city are you in and how old is your battery?

perfectly normal for a CEL to be accompanied by a disabled cruise and other systems nowadays. The car's computer will always do that. doesn't mean the cruise control is involved at all.
 

·
Registered
Joined
·
36 Posts
Discussion Starter #4
Thanks and I'll ask for the code when they call me again. I live in Minneapolis and the battery is as old as the car (6 yrs).

ask them for the DTC (the stored code or codes that they scanned) and post them here.

what city are you in and how old is your battery?

perfectly normal for a CEL to be accompanied by a disabled cruise and other systems nowadays. The car's computer will always do that. doesn't mean the cruise control is involved at all.
 

·
Registered
Joined
·
36 Posts
Discussion Starter #7
OK, dealer called again and nothing was found/done. I did get the code and it is P0016. Any idea what the error code is about?

ask them for the DTC (the stored code or codes that they scanned) and post them here.

what city are you in and how old is your battery?

perfectly normal for a CEL to be accompanied by a disabled cruise and other systems nowadays. The car's computer will always do that. doesn't mean the cruise control is involved at all.
 

·
I simply cannot abide useless people.
2006 2.5i and 2002 3.0 wagons.
Joined
·
12,304 Posts

·
Registered
Joined
·
18,427 Posts
I don't see P0016 in the service manuals I have. Strange. Are you sure the dealer gave you this, or can you confirm it with the dealer? Or bring the car to Autozone or one of the other major parts stores that will read the code, often for free. Just get the code read and repost here.

(It's a 2006 LLBean which has the 6 cylinder engine and 5-speed automatic transmission.)

Other than the CEL and flashing cruise control lights, are there any other symptoms, such as engine misfiring, unable to start the engine, or it stalls, or no acceleration, etc?
 

·
Premium Member
03 H6 OBW & 06 WRX Sportwagon
Joined
·
17,839 Posts
brief search yields hits for cranshaft position sensor, or crank/camshaft postion sensor disagreement ???

I would clear the code, montor how soon it or other codes return.

I'd consider a weak battery 'could' cause spurious codes to set. It has happened to me. So, perhaps have the battery tested. (if you do need a replacement, I like the top-of-the-line O'reilly, but it's your choice, could weather needs are different than ours down here.)

how many miles on the car? any other oddities? (noises, electrical problems, wrecks, modifications, recent repairs, etc.?)
 

·
Registered
Joined
·
36 Posts
Discussion Starter #12
Thanks to everyone for your suggestions and help.

The car is getting close to 60K miles. So far there hasn't been any noticeable issues other than the following:
1. Check engine light and cruise light as mentioned here
2. Higher/rougher engine noise when driving about a month ago. Dealer did an oil change and was good since then. I had been doing oil change myself before this last one. I was using 5W-30 Pennoil and Subaru blue filter. I got Subaru synthetic 5W-30 stocked up for future oil change.

brief search yields hits for cranshaft position sensor, or crank/camshaft postion sensor disagreement ???

I would clear the code, montor how soon it or other codes return.

I'd consider a weak battery 'could' cause spurious codes to set. It has happened to me. So, perhaps have the battery tested. (if you do need a replacement, I like the top-of-the-line O'reilly, but it's your choice, could weather needs are different than ours down here.)

how many miles on the car? any other oddities? (noises, electrical problems, wrecks, modifications, recent repairs, etc.?)
 
1 - 12 of 12 Posts
Top