Subaru Outback Forums banner

1 - 20 of 40 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
While driving down the highway in my 2011 Outback, my 'check engine' light suddenly went on, the 'brake' light flashed, another light came on indicating a car sliding, another light that was a picture of a headlight, my remote was disabled, and my Nav system went on and off. My Subaru dealer couldn't take me for 3 weeks. The night before my scheduled appointment, I hit a small bump, and everything righted itself. Subaru dealer was mystified, but obviously couldn't care less, claimed they had nowhere to document this incident, and said they probably couldn't find anything wrong if I bothered to bring the car in (dealership is an hour and 15 minutes away so I decided not to). Has anybody had this happen to them?
 

·
Registered
2011 Outback Limited 2.5i/2018 Crosstrek limited
Joined
·
4,764 Posts
...You're not the first person to have had this problem...and by the sounds of how many have posted about this issue with their OB....you won't be the last...hopefully it's just the gas cap....

I left mine loose just to see what would happen...nothing!
 

·
Registered
Joined
·
1 Posts
Check Engine, Brake, Cruise Control, and Traction lights on

I am having the same problem with my 2011 Outback. This morning while driving to work on the freeway my Check Engine, Traction, Cruise Control, and Brake lights appeared on the dash. The dealer told me to check the gas cap. I did and this did not correct the problem. The dealer is my next destination. I will post what they tell me.
 

·
Registered
Joined
·
3 Posts
Yep, mine did this when I was headed home with about 3.5 hours to go... It also disengaged the cruise control, which was a pain in the butt on a long trip! Turns out it was the gas cap... Dealer reset the faults, and replace the gas cap... no issues since. That was about 3k miles and 6 months ago.
 

·
Registered
2011 OB Prem 6 spd now 2006 Built WRX.
Joined
·
866 Posts
This happened to my parents brand new 3.6 during the first 3k miles while my mom was driving it to Montana for a family reunion. Dealer is replacing something on Tuesday, I will have to post up later with more info regarding the issue... Its bothersome this happens with BRAND NEW cars.
 

·
Registered
Joined
·
3 Posts
This just happened to new OB I got in Dec 2010.

Is it just the lights that are on? or are some of the systems actually deactivated (for example the traction control)?

I hope that it is just the warning lights and not a malfunction, because I commute 45mi back and forth from work every day
 

·
Registered
Joined
·
1 Posts
On my 3rd trip to the dealership for this issue. Has happened twice during a first morning start using OEM remote start unit. Third was just during normal driving and use of cruise control. The remote starter would sense a problem and shut down after initial start. When I'd manually start it the dash lights would all start flashing. Service department said it is a 'known' cold start problem with a fix on the way soon. Re-flashing or reprogramming of ECU with new program is promised repair. So I'll see how close the new re-flash is to being released the 3rd time I bring it in.
 

·
Registered
2015 Jeep Grand Cherokee, 2011 WRX, 2015 Legacy 3.6r loaded and a 2016 Camaro 2SS.
Joined
·
124 Posts
On my 3rd trip to the dealership for this issue. Has happened twice during a first morning start using OEM remote start unit. Third was just during normal driving and use of cruise control. The remote starter would sense a problem and shut down after initial start. When I'd manually start it the dash lights would all start flashing. Service department said it is a 'known' cold start problem with a fix on the way soon. Re-flashing or reprogramming of ECU with new program is promised repair. So I'll see how close the new re-flash is to being released the 3rd time I bring it in.
This happenend to my 2 day old Outback, and new sw fixed it. You dealer should have it!
 

·
Registered
2010 Outback, 6-speed manual
Joined
·
16 Posts
I'm having the same problem here with my 2010 Outback 2.5. Check Engine light, Traction Control light went solid-on, and emergency brake light and cruise control indicator started flashing. Haven't tried replacing gas cap, but will be taking to dealer soon.
 

·
Registered
2009 2.5i Outback Limited
Joined
·
64 Posts
With all the changes I'm glad I got the 09 Outback.
I got to drive the 2011 with all the bells and whistles. It was cool at first but after an afternoon of driving around and fiddling around with all the toys it fast became apparent that there's just too much going on. And with all the new gadgets there's a huge door open for problems.

As for the check engine light, I have heard that a lose gas cap can cause problems and will light up the check engine light. As for all the other lights coming on, that sounds like a more complex problem.
I'm sorry your dealer is very un-caring. My old dealer was a bunch of idiots but thank God they sold out and another dealer has taken Subaru over in Lexington, KY.

I've owned allot of different cars over my lifetime and I do know that the local dealer determines how people perceive the brand.
You should complain to Subaru directly. If enough people complain Subaru will yank their name off the dealer so fast it'll make your head spin because it's their reputation on the line, as well as the dealer.
 

·
Registered
Joined
·
3 Posts
I'm having the same problem here with my 2010 Outback 2.5. Check Engine light, Traction Control light went solid-on, and emergency brake light and cruise control indicator started flashing. Haven't tried replacing gas cap, but will be taking to dealer soon.
So it was the gas cap for me. Just makr sure its nice and tight. After you recap tightly it takes about 10 on / off cycles for the lights to go back to normal
 

·
Registered
Joined
·
2 Posts
This just happened to me on my way home. After reading this forum I went and checked my gas cap and it has a tear in the rubber seal. I will take to the dealership tomorrow and post the results. Can't believe all of those lights for a gas cap!
 

·
Registered
2010 Outback, 6-speed manual
Joined
·
16 Posts
So it was the gas cap for me. Just makr sure its nice and tight. After you recap tightly it takes about 10 on / off cycles for the lights to go back to normal
Thanks for that. On inspection, I do have a tear in the gas cap gasket, so will have to replace. Thanks for the tip!
 

·
Registered
Joined
·
1,142 Posts
While driving down the highway in my 2011 Outback, my 'check engine' light suddenly went on, the 'brake' light flashed, another light came on indicating a car sliding, another light that was a picture of a headlight, my remote was disabled, and my Nav system went on and off. My Subaru dealer couldn't take me for 3 weeks. The night before my scheduled appointment, I hit a small bump, and everything righted itself. Subaru dealer was mystified, but obviously couldn't care less, claimed they had nowhere to document this incident, and said they probably couldn't find anything wrong if I bothered to bring the car in (dealership is an hour and 15 minutes away so I decided not to). Has anybody had this happen to them?
If you have a 3.6 there is a TSB on this for a chronic P0128 code that requires replacing a coolant pipe with and updated part.
 

·
Registered
Joined
·
2 Posts
Took it to the dealer today. They replaced the gas cap and reset the codes and problem fixed at no cost and under warranty. The service adviser also said this could happen if you fill up the tank while the engine is running. If the computer runs the check with no fuel cap the same codes will appear.
 

·
Registered
2010 Outback, 6-speed manual
Joined
·
16 Posts
Thanks for that. On inspection, I do have a tear in the gas cap gasket, so will have to replace. Thanks for the tip!
...and, despite the fact that my wife, when bringing it to the dealer, told them to just replace the gas cap (and skip the diags) they did the diags anyhow & charged her $118 for it. Argh. But it was the problem. Just a ripped gasket on the gas cap itself. Dealer said it made all of the lights light up, because as soon as the gas recirc breaks due to vapor coming out of the tank, the computer errors, meaning the trac doesn't work, and also cruise won't work. Thus all of the flashy lights.
 

·
Registered
Joined
·
2 Posts
Solid Engine Light, Traction Light, and Brake Light Blinking

Model: 2011/SUBARU/OUTBACK/4DR/ 2.5I Premium (PZEV)
Miles: 9,456
Issue: Started car this morning check engine light was solid, traction control light was on, and brake light was blinking.
Location: Fort Bliss, TX

Resolution: Called dealership asked if I had just recently put gas in. Advised a few days ago. They asked that I bring it in.
It turned out it was a cold start idle issue and that a firmware upgrade was available to correct the problem.

Here is the invoice for the work:

P050A Cold Start Idle Air Control System
A455-288/.04 UPG48

Performed Diagnostics and installed latest re-flash

Hope this helps!!!!
 
1 - 20 of 40 Posts
Top