Subaru Outback Forums banner
  • Hey everyone! Enter your ride HERE to be a part of October's Outback of the Month Challenge!
1 - 16 of 16 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hello,
I picked up my new Outback 3.6 Limited Special Appearance Package last night. And tonight, on the way home from work (<100 miles on the odometer), the check engine and several other lights came on and stayed on. I am not sure if it is safe to drive.
I called the dealer and am scheduled to bring it in tomorrow morning.
I am so disappointed! This is my first Subaru (traded in my Toyota) and I never expected to have any problems!
Any words of wisdom?
-PF
 

·
Registered
2005 OBW 2.5L, 1989 Subaru Justy, RIP Blu
Joined
·
7,355 Posts
Cars are terribly complex things, and stuff happens. Have the dealer read the codes as it may be something simple.
 

·
Registered
Joined
·
55 Posts
For the two cars I bought new (and my Subaru included) the check engine light came on within a week of purchasing the car. In each case the PCV valve required changing. I wouldn't worry too much about having to take it in unexpectedly.
 

·
Registered
2012 Limited Outback CVT 2.5i with OEM: Hitch, Hood Protector, & Remote Start.
Joined
·
154 Posts
This just happened to me, although mine is 16 months old with 32,000 miles on it, never any problem until the Cruise & Brake Lights started flashing and Check Engine Light came on. Dealership ran the diagnostics and could not find anything wrong so they reset everything and said not to worry. One of the most common reasons that I found using google search is the gas cap not being tightened and others reported a software patch named "WVU-31" which many people needed to fix the problem. Service said I had the patch and that it was not the gas cap (this time), just a "software glitch"...
Still when all those lights come on it's hard not to worry. I'm sure the dealership will take care of you. Can't help but think it's time to purchase an extended warranty before the factory runs out. The dealership charged Subaru $316 to diagnose my problem (ouch).
 

·
Registered
Joined
·
2 Posts
Same problem as well.

This just happened to me, although mine is 16 months old with 32,000 miles on it, never any problem until the Cruise & Brake Lights started flashing and Check Engine Light came on. Dealership ran the diagnostics and could not find anything wrong so they reset everything and said not to worry. One of the most common reasons that I found using google search is the gas cap not being tightened and others reported a software patch named "WVU-31" which many people needed to fix the problem. Service said I had the patch and that it was not the gas cap (this time), just a "software glitch"...
Still when all those lights come on it's hard not to worry. I'm sure the dealership will take care of you. Can't help but think it's time to purchase an extended warranty before the factory runs out. The dealership charged Subaru $316 to diagnose my problem (ouch).[/QU:)

i my name is lisa and i have a 2005 subura out back i am haveing the same problem with my car.. i change gas cap ...and it is still doing it ...CRUISE AND ENGINE LIGHT ... SO I TAKE CABLE OFF THE BATEERY TO RESITE FOR A WHILE .......PLEASE HELP ME THANK YOU
 

·
Registered
Joined
·
2 Posts
Please help my cruise light and engine light keeps blicking changed gas cap some one told me it could be bank 1 and bank 2 o2 sensor....please help me lisa
 

·
Meh.
I has wagons.
Joined
·
12,372 Posts
Without knowing the codes, we can't say at all. You have no data.

Get the codes read. I don't know where you are (as you have no location listed) , but in the US most any Autozone type store will read the codes for free.

Get the codes, report back.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #8 ·
Update: The code found in my case was p0751 (Fluid level) but nothing was found. Tech line advised trying a "learn" on transmission which they did. So far, no further problems and up to about 600 miles now. Hopefully, it won't happen again.
 

·
Registered
Car: 2008 Tribeca, 2010 LGT, Sold: 2005 XT Limited
Joined
·
2,926 Posts
P0751 SUBARU Description

Shift solenoid valve A is turned ON or OFF by the Transmission Control Module (TCM) in response to signals sent from the park/neutral position (PNP) switch, vehicle speed and Engine Control Module (ECM) (throttle opening). Gears will then be shifted to the optimum position

When the a transmission solenoid is stuck off, in most cases the problem is not the electrical part of the solenoid; the problem is foreign material obstructing the mechanical function of the solenoid or the flow of the fluid through the transmission valve body. If the transmission fluid is very dirty, it is recommend changing the transmission fluid and if possible removing the transmission pan for further diagnosis. Excessive debris or metal particles on the transmission pan could be an indication that there is a transmission mechanical failure and that the transmission will need to be rebuilt or replaced.

Read more: OBD2-OBDII Engine Light Trouble Code P0751 SUBARU - Shift Solenoid A Performance or Stuck Off | Engine-Codes.com
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #10 ·
tdelker - wow, thanks for that link. I guess I will bring this up with the dealer if it happens again. I just drove up to Maine (from Boston) and back without any problems - great car!
 

·
Registered
2012 Limited Outback CVT 2.5i with OEM: Hitch, Hood Protector, & Remote Start.
Joined
·
154 Posts
Just happened to me again w all the flashing lights & check engine lite on- codes :
P0700&P0841
Runs better in manual shift mode- on the way to dealer now
 

·
Premium Member
01 VDC, 05 R Sedan, 06 BAJA EJ257
Joined
·
16,285 Posts
Just happened to me again w all the flashing lights & check engine lite on- codes :
P0700&P0841
Runs better in manual shift mode- on the way to dealer now
700 is a general transmission MIL request code to turn on the MIL to get your attention.

The 841 is a pressure sensor or control valve issue. Have you checked the fluid level/condition?
 

·
Registered
2012 Limited Outback CVT 2.5i with OEM: Hitch, Hood Protector, & Remote Start.
Joined
·
154 Posts
Fluid/level condition

700 is a general transmission MIL request code to turn on the MIL to get your attention.

The 841 is a pressure sensor or control valve issue. Have you checked the fluid level/condition?
Recently had 30k service- this has happened twice in 3 weeks- at dealer now & hope to know more tomorrow- runs fine in Manual but runs horrible in Drive
 

·
Registered
2012 Limited Outback CVT 2.5i with OEM: Hitch, Hood Protector, & Remote Start.
Joined
·
154 Posts
Wondering if this is related to recall flash they did w 30K service?
 

·
Registered
2012 Limited Outback CVT 2.5i with OEM: Hitch, Hood Protector, & Remote Start.
Joined
·
154 Posts
Not the fluid level. Dealer had car all day. Needs a New CVT transmission which has been ordered. Should come in by Wednesday. Ready to hit the road again Thursday or Friday. Wow! I wonder how many times this has happened since 2012???
Since I'm keeping the car for 3 more years I recently purchased the Subaru Gold Extended Warranty good till 100,000. Cheap insurance for cheap of mind ($995)
Cleve
 
1 - 16 of 16 Posts
Top