Subaru Outback Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello all. New to forum, Just bought a 2005 outback 3.0R sedan. Has 175K and cruise control light blinks, along with check engine light. Other than that, the car runs great and feels solid. Any one with insight to a fix would be greatly appreciated!
 

·
Registered
85BRAT97SVX03Baja5mtHonda's
Joined
·
2,174 Posts
wheel bearing speed sensor issue. probably had new hub bearings installed that are not OEM

Have your codes read (most autopart stores read for no charge) then report back the codes before you go any further into repairs.
 

·
Registered
Joined
·
61 Posts
try scanning for codes:

nothing may show up on the on board scan tool but its worth a try.
some codes will require a more elaborate scan tool
 

·
Registered
2008 Outback 2.5i, 2009 Forrester 2.5 sohc
Joined
·
606 Posts
Have the code read and re post. The Cruise stops operating ( i think for all codes) if the CEL light is on.
 

·
Registered
Lawn ornament XT
Joined
·
14,366 Posts
Have the code read and re post. The Cruise stops operating ( i think for all codes) if the CEL light is on.
This is correct- cruise control is disabled and marked by a blinking indicator light whenever the check-engine light is on. Keeps the car from potentially destroying itself.
 

·
Registered
2005 OBXT Limited, VF37, STI intake, 5MT
Joined
·
1,559 Posts
I highly suggest reading the owner's manual with special attention to warning lights: whenever a CEL is on, the cruise blinks (and is disabled). Standard operating procedure with Subarus.
 
1 - 8 of 8 Posts
Top