Subaru Outback Forums banner
  • Hey everyone! Enter your ride HERE to be a part of October's Outback of the Month Challenge!
1 - 3 of 3 Posts

·
Registered
1997 Subaru Legacy OBW w/EJ22 M/T
Joined
·
24 Posts
Discussion Starter · #1 ·
Hey guys, got a real fun problem for you guys and I have searched EVERYWHERE with no answer.

I have a '97 Legacy Outback with a 2.2L swap (was 2.5L) and started having the SW Lighting Fuse issue where your radio and lights don't illuminate. So go to the Main Fuse box and swap the fuse. But, no dice. =/ so i check the fuse, throw a VOM on both sides, grounding to the battery, and I'm getting 12.5V on each side. So the fuse is good. Going underneath the steering wheel and moving around some wires brings all the int lights back on. So its definitely a harness somewhere. But, while trying to take out the dashboard I realized that its dang near impossible to. So, anybody have ANY idea what the location for the wire that powers the Radio and Int Lights is? I've tried wiggling random harnesses and watching the lights but they don't seem to come on consistently with any harness. Or does it have a distribution box somewhere with a harness that may be loose? Or is there any tricks to getting the dashboard off so I can trace the wire back to its source? I'm open to any suggestions, right now this issue is just too frustrating to tackle by myself, so I'm seeing if any of you guys have had this issue before. :confused:

Thanks for reading,

Paul
 

·
Registered
Joined
·
19,395 Posts
Is it only the lights that are out? I ask because I recall similar reports here where it turned out the dash brightness controller had failed. In your case, perhaps it's just the connector at the back is loose. (I think it's at the lower left of the dash board.)
 

·
Registered
1997 Subaru Legacy OBW w/EJ22 M/T
Joined
·
24 Posts
Discussion Starter · #3 ·
Thanks for your suggestion! Unfortunately, the radio cut out, which is why I noticed it. In fact if it wasn't for the radio i wouldn't even have cared xD But I noticed something last night. When it gets really hot out, the lights never work. But yesterday I left the dome light in "always on" position by accident, and i noticed that when it cooled down at night, boom they came right back on. So now this thing has got me wondering again haha. I hope I can figure this thing out. Worst comes to worst, I just throw a wire and diode to the 12V Constant from the 12V Accy. At least it will give me a radio when the car is on. This will give me time to maybe ask a couple Subaru dealerships what they think. When I bought the car, I found that the Back Up Switch on the tranny was completely ripped off and E-Taped... So I think when he was swapping the engine he forgot to disconnect a couple harnesses...:rolleyes: So there is really is a small chance that it's not something he did haha. But I still love this thing. 200,000 Miles on the clock and it still runs like brand new.

Thanks!
 
1 - 3 of 3 Posts
Top