Subaru Outback Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 6 of 6 Posts

·
Registered
2008 OBW
Joined
·
3 Posts
Discussion Starter #1
Random electrical issues have been cropping up in my 08 OBW...

  1. The volume on the radio randomly goes up and down on its own
  2. Airbag dashboard light randomly comes on and goes off
  3. Driver's side headlamp, you guessed it, randomly doesn't work
  4. Aux plug in to iPod is also acting up, causing volume to increase or drop out entirely
Just in the last couple of days, I've noticed a strange, almost electrical/hot smell in the cabin after about 20 minutes of driving. No smell under the hood or outside of the vehicle, just inside.

My first thought was a bad harness or early signs of the alternator about to take a dump. 90k miles on this subiedoo, daily mountain driving over mag chloride roads.

Any thoughts before I take it to the shop?
 

·
Registered
Somebody Else's XT
Joined
·
14,437 Posts
It can, but it could also be another component unhappy with overvoltage. Bad grounds can fake out the alternator- cause it to give too little or too much power. Or both conditions at different times. Most electronics hate spiky dirty power, so this could be something else on the edge of frying as a result.

Either way, start with cleaning & tightening the grounds and then testing the alt output.
 

·
Registered
2008 OBW
Joined
·
3 Posts
Discussion Starter #5
It can, but it could also be another component unhappy with overvoltage. Bad grounds can fake out the alternator- cause it to give too little or too much power. Or both conditions at different times. Most electronics hate spiky dirty power, so this could be something else on the edge of frying as a result.

Either way, start with cleaning & tightening the grounds and then testing the alt output.
Got it! Thanks, rasterman.
 

·
Registered
Joined
·
50 Posts
I got the airbag problem. I replace my low beams more often than I like too. I just replaced my alternator. If it is make a high pitch whining noise it is about to go? Didn't solve the airbag came on today but it seems more frequent at temps under 15F. Oh and the tailgate is stuck in the open position? Mechanic says it is an electrical issue. I have not try to resolve it as it seems like a time consuming process which means $$$.
 
1 - 6 of 6 Posts
Top