Subaru Outback Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
OB Sedan 3L... My Engine Light came on today (3 miles from home) and a few minutes later while at a red light my gas pedal did not do anything. I shifted into neutral and the car rev'd at 2K, and I tried to hit the gas to settle it down, but nothing happened. Floored the gas - nothing. I was lucky there was a gas station on the corner, idled to parking lot, turned off engine, looked under hood (it has oil). Restarted car, and was able to drive home.

Any ideas? I don't have a check engine meter to figure-out the code.
 

·
Super Moderator
Joined
·
12,109 Posts
Get to an autoparts store and get the code read.
 

·
Registered
Joined
·
16,300 Posts
ditto -- have the code read.

The fact that the gas peddle was inoperative and the engine was at 2000 rpm in neutral suggests the ECM went into failsafe mode.

I wonder if there were any symptoms (other than the CEL being on) after restarting, or did the car run normally then.
 

·
Registered
Joined
·
2,926 Posts

·
Registered
Joined
·
28 Posts
I had this happen to mine, same model, 06 OB sedan 3L LL bean. I'd let it sit for a few minutes, the first time I tried to start it, it wouldn't start but the second time it would. CEL would stay on for a day or so.

Ended up getting a new gas pedal which fixed the problem.
 
1 - 6 of 6 Posts
About this Discussion
5 Replies
7 Participants
Karen
Subaru Outback Forums
Welcome to the Subaru Outback Owners Forum, we have tons of information about your Subaru Outback, from a Subaru Outback Wiki to customer reviews.
Full Forum Listing
Top