Subaru Outback Forums banner
  • Hey everyone! Enter your ride HERE to be a part of October's Outback of the Month Challenge!
1 - 5 of 5 Posts

·
Registered
‘21 OB XT Touring
Joined
·
26 Posts
Discussion Starter · #1 ·
I'm having issues with my infotainment unit when I use CarPlay. Bluetooth works fine. I'm wondering if anyone has experience anything similar, particularly on a 2021 HK system.

The main issue is that 4/5 times when I plug in the phone and use Spotify (the only streaming service I use) all the speakers go mute except for the two dash speakers, which I don't think they are full range speakers because only higher freq. sound comes out. This happens sporadically on Sirius and once on FM radio, except there was no audio at all. Also, once I plug in the phone the media and radio buttons on the screen stop responding. I have to unplug, change audio source, and reconnect the phone.

I looked into the giga-thread to update the software, but first I tried updating my iOS. I'm on version 7.4 now and the problem persisted. So I made an appointment at the dealership to get it check out and they said there was a recall for my current version I was on 500. I figured the update to the newest 980 version would fix the problem but it did not. The Subaru tech happened to have the same iPhone model that I have and his worked fine every time on Apple music. I killed Spotify on my phone and tried YouTube, and dowloaded Apple Music afterward, and everything seems fine now.

So now I know the problem is Spotify, which sucks because I pay for a family subscription and have built up a good amount of playlists. At this point I don't know if my unit is defective, or the Spotify app is corrupting things.
 

·
Registered
Joined
·
2 Posts
I have had issues with Spotify in my 2021 XT with HK system; I also have issues in my Ram 1500. I am using an iPhone 12 Pro Max with the latest software from Apple and an Apple USB cable. I have learned to not use the CarPlay interface to navigate the Spotify app at the start. I plug my phone into the the USB cable. I wait for CarPlay to initialize on the vehicles screen. I then launch Spotify on my phone and select my playlist, etc. Once the music starts, I use the CarPlay - Spotify app for the rest of my navigation. I have not had this issue with Apple Music. I have had similar issues with the SiriusXM app. Sometimes it will load and sometimes it won't from CarPlay. The SiriusXM app will always load when launched from my phone's screen.

I updated my Infotainment to 980 and there was no change. I truly believe it is a glitch with the Spotify app since I have the same issue in two totally different vehicles. It could just be me, but that is my two cents worth..
 

·
Registered
Joined
·
5 Posts
I am having this issue with calls - whether using Apple CarPlay or bluetooth. I’ve also had issues with the software updates and plan to take my car in for service.

I recently upgraded to the iPhone 12 but that doesn’t sound like it is the same issue. I’ve been really disappointed w/the entire system; it’s slow, the radio gets stuck or just doesn’t work and Car Play can be spotty.

I’ll try my Spotify connection tomorrow and see how that goes!
 

·
Registered
‘21 OB XT Touring
Joined
·
26 Posts
Discussion Starter · #4 ·
The newest update helps with the glitches and responsiveness of the system. I deleted my phone from the car and deleted the CarPlay connection from my phone at the advice of another member. It worked fine the first time. But then the all the same issues continued. I’ve been running the app on my phone before I plug it in and that seems to work somewhat ok most of the time. I think it’s time to write to Spotify. Their app is the problem here.
 
1 - 5 of 5 Posts
Top