Subaru Outback Forums banner
  • Hey everyone! Enter your ride HERE to be a part of September's Outback of the Month Challenge!
1 - 15 of 15 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Greetings Soobie community, you may be wondering why the title? Well, it's because my '86 with over 300k miles has been a no nonsense car for me for over 27 years. The '96, not so much. Briefly, I rescued the '96 with 165k miles and it obviously had little to no maintenance. I have put 30k miles on it. I knew I had my work cut out for me but, Subaru in the midwest is the proper commuter. My '86 is disintegrating as we speak and the '96 was bought from a no salt state. That being said, I skip forward to my present issue: Low idle and absolutely no accel. Merely touching the throttle results in bucking, a fart and death. I won't bore you with what I've done, so your ideas, even tho they may be repeats, will be greatly appreciated. This all started when I let the car sit about a month and the battery croaked within that month. Latest fix, fuel pressure regulator DID have fuel on the vacuum side so that was changed. Thank You.
 

·
On the Super Mod Squad
2002 3.0 VDC Wag + 2018 2.5 Leg Ltd
Joined
·
27,054 Posts
manual or automatic on that 1996?

(2 different engines between the 2, a gem Ej22 and a turd Ej25D).

and moving thread.
 

·
On the Super Mod Squad
2002 3.0 VDC Wag + 2018 2.5 Leg Ltd
Joined
·
27,054 Posts
Automatic. 2.5 dohc. I think I prefer pushrods..............
that first year EJ25D has some unique parts in it vs. the later ones. as it wants to run on premium 91 plus octane. (later ones had changes to the heads / valves /pistons permitting regular gas).

if in the process of figuring out what is wrong with it, and you think it is terminal maybe consider the right EJ22 for it with this thread :

http://www.subaruoutback.org/forums...248329-ej22-swap-into-ej25d-dohc-vehicle.html
 

·
On the Super Mod Squad
2002 3.0 VDC Wag + 2018 2.5 Leg Ltd
Joined
·
27,054 Posts
That being said, I skip forward to my present issue: Low idle and absolutely no accel. Merely touching the throttle results in bucking, a fart and death. I won't bore you with what I've done, so your ideas, even tho they may be repeats, will be greatly appreciated. This all started when I let the car sit about a month and the battery croaked within that month. Latest fix, fuel pressure regulator DID have fuel on the vacuum side so that was changed. Thank You.
do you think it is a electrical issue? (like a engine ground that moves when the engine wiggles under load).

something with the throttle?

something with the gas that it has ? (like getting water or a solid stuck in the fuel pickup as soon as you touch the accelerator?)

anything stick out to MR XT6 owner,... subaru USMB mod @idosubaru ? (I edited down post one to just the matter at hand).
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #6 ·
Thx Eagleeye, yes to electrical. broken wire perhaps, what component? I'm looking. Fuel system, removed/cleaned throttle body. installed in line pressure gauge, solid 36 psi. Vacuum issue? Sprayed Gumout all over, no rpm spikes.
 

·
On the Super Mod Squad
2002 3.0 VDC Wag + 2018 2.5 Leg Ltd
Joined
·
27,054 Posts
thx Eagleeye, yes for electrical. Broken wire, mouse chewed. Or a related component that would cause low idle no accel. Thoroughly cleaned throttle body, removed and cleaned. Installed in line pressure gauge, solid 36 psi. Car was running fine, just parked it and drove another car. Sat for about a month. Went to use it, dead battery. No biggie, threw a battery in, hard starting but it had been sitting, idled at 300-400 and would not accel. Battery croaked and took something with it? I have been looking for bad wire, no joy as of yet. Plenty more wires to inspect tho.
slice open the sheaths on the battery cables. and inspect for corrosion. (with a nice roll of electrical tape in hand).

these years also had a recall on the alternator long long ago.

as such subaru made many more reman's availble then they ever could sell. so $75 buys you the OEM, and at this late date maybe no core either. (probably have to wait a day for them to round one up out of the regional warehouse though).
I think this would also do as you say the car is doing. like as soon as the alternator starts to do its needed work, it shorts and the car dies.

and if you get the OEM, you need not fiddle with the crooked parts stores overcharging for junk .
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #9 ·
Good morning Eagleeye, I seem to be having trouble navigating the website. No surprise. My initial post said "Private message." does this not reach out? I am looking at and adding to additional grounds, however, I did check wiring and battery volage is available at all points checked. Thx
 

·
On the Super Mod Squad
2002 3.0 VDC Wag + 2018 2.5 Leg Ltd
Joined
·
27,054 Posts
Good morning Eagleeye, I seem to be having trouble navigating the website. No surprise. My initial post said "Private message." does this not reach out? I am looking at and adding to additional grounds, however, I did check wiring and battery volage is available at all points checked. Thx
as a anti-spam bot measure the admins made it so one needs 10 public posts on an account to Private message. at this moment you got 5.
 

·
Registered
1997 Outback 2.5 AT
Joined
·
186 Posts
is your MAF sensor an original Subaru piece or an aftermarket parts-store replacement (junk)?

i chased an intermittent stalling/bucking/rough idle issue for 6 months that resulted in 4 50+ mile tows...turned out to be the autozone MAF the previous owner had installed took a ****.
PO put the autozone MAF on because the PO's PO was stupid enough to fit a K&N filter on a MAF car which killed the original MAF.

i got a good Subaru MAF (3 actually) from the boneyard and swapped it out in 2 minutes and the car runs sweeeeeeet now.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #12 ·
I see. Good. Just making sure I was getting out. Fuel filter wasn't old, but I changed it anyway. Fresh gas and a little seafoam. Letting it idle.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #13 ·
Thx. Original MAF as for as I know. Pull connector and it dies. sucks getting towed, but I can't move with idle at 300-400. I will investigate MAF a little further.
 

·
On the Super Mod Squad
2002 3.0 VDC Wag + 2018 2.5 Leg Ltd
Joined
·
27,054 Posts
Thx. Original MAF as for as I know. Pull connector and it dies. sucks getting towed, but I can't move with idle at 300-400. I will investigate MAF a little further.
I hope you mean flatbedded = the subaru way.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #15 ·
Found a "Recycler" in California, picked up an airbox and MAF sensor, r and r'd both, minute improvement in idle. ECU is coming. Sounds like a shotgun doesn't it? Actually quite a bit of research here. Appreciating all the Forums and the info shared................
 
1 - 15 of 15 Posts
Top