Subaru Outback Forums banner

1 - 6 of 6 Posts

·
Registered
2012 Outback 3.6R
Joined
·
4 Posts
Discussion Starter #1
Hello

I have a 2012 Outback R3.6 with 84k miles on it. About a month ago my dashboard lights lit up and the code was related to the transmission. The shop replaced the valve module? for about 1900. Today I am getting vibration around 45 mph, which sounds like torque converter shudder based on posts I found. Are these problems related?

About two months ago I had the transmission fluid changed.

Should I have the transmission fluid replaced? Try the Lubeguard additive?

thanks
Patrick
 

·
On the Super Mod Squad
2002 Pair: 3.0 VDC Wag & 2.5 Limited Sedan
Joined
·
26,194 Posts
what trans fluid did they use?

this 5EAT takes subaru hp fluid. (...some higher grade spec over regular dexron stuff,...so maybe one rare higher spec amszoil type is the alternative).
 

·
Registered
2012 Outback 3.6R
Joined
·
4 Posts
Discussion Starter #3
I had the dealer do the fluid so I assume they used the correct one. The other work was done by local repair shop.
 

·
Registered
2010 Subaru Outback 3.6r
Joined
·
98 Posts
is the shudder very pronounced? I'm still unclear on how it feels, or does it just feel like an unbalanced tire?
 

·
Registered
2012 Outback 3.6R
Joined
·
4 Posts
Discussion Starter #5
It feels like driving over washboard. I had the tires balanced and also confirmed with the mechanic they used subaru atf when they fixed the valve body. I took it back to the mechanic today and they haven't figured out what it is yet. I'll have to take it back tomorrow. On their test drive they didn't feel the vibration.
 

·
Registered
2012 Outback 3.6R
Joined
·
4 Posts
Discussion Starter #6
Mechanic believes it is the drive shaft. Ordered a used one and hope to get it installed this week.
 
1 - 6 of 6 Posts
Top