Subaru Outback Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I just picked up a '97 Subaru outback and it shifts smooth and the trans operates with no problems. The only issue I'm having is that it's really hard to press in the clutch pedal so much that my foot is actually hurting! Any suggestions? The guy at my work has the same year and model as mine and his clutch is easy to push in. Seriously my foot hurts and if I can't fix this issue I may no longer want this car lol. Any help is appreciated! Thanks
 

·
Registered
Joined
·
22,802 Posts
I just picked up a '97 Subaru outback and it shifts smooth and the trans operates with no problems. The only issue I'm having is that it's really hard to press in the clutch pedal so much that my foot is actually hurting! Any suggestions? The guy at my work has the same year and model as mine and his clutch is easy to push in. Seriously my foot hurts and if I can't fix this issue I may no longer want this car lol. Any help is appreciated! Thanks
Just a guess - they are hydraulic clutches if the fluid is super old or low it might operate hard like that. Or the little cylinder your activating is shot - cheap fix either way.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Thanks! The fluid that's in there is black...I'm guessing that's not good? Lol. I'll get a new slave while I'm at it and hoses. Thanks again.
 
1 - 4 of 4 Posts
Top