Subaru Outback Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
I have a '98 Outback with a 5 speed and the 2.5L and the HG went out a few months ago just before my wedding. My father-in-law is my mechanic and he and his friend did the HG for me. He had the heads resurfaced and got everything back on and back to me.

When I got it back, it had a very loud 'ticking' coming from the heads. Before the HG blew, there was a very slight ticking but nowhere near as loud as it is now. It settles down a bit once idle settles but I can still hear it at anything above 1000 RPMs.

Soon after getting back, the car threw PO303 and PO304 misfire codes and was hesitating on me once the car was warm. I drove it the other day on the freeway and between 2.5k and 3.5k RPMs it would hesitate real bad and I couldn't get it to accelerate. When I got home the idle hunted between 350 and 1000 RPMs. Not safe.

I've given it to my FIL twice and he said he checked spark but can't find anything wrong with it. I found a guy with the same exact problem, with no mention of the loud ticking, on another forum and he ended adjusting the valves and it fixed his problem.

Has anyone else experienced something similar? I know that there are a lot of places to check when getting misfiring codes. I'm itching to get this fixed. I've owned a lot of cars and have never had a problem exist for this long and not get fixed. Thanks in advance!
 
1 - 2 of 2 Posts
About this Discussion
1 Reply
2 Participants
1 Lucky Texan
Subaru Outback Forums
Welcome to the Subaru Outback Owners Forum, we have tons of information about your Subaru Outback, from a Subaru Outback Wiki to customer reviews.
Full Forum Listing
Top