Subaru Outback Forums banner
1 - 13 of 13 Posts

·
Registered
2020 OB Touring - Canadian version
Joined
·
16 Posts
Discussion Starter · #1 ·
Hi,

Just today wifie calls me that our 2020 Touring (Canadian version) dashboard is lit like a X-mas tree.

CEL is on, RAB is disabled, Eyesight is off (check the manual message) , Xmode is flashing, pre-colision braking light is on, lane departure is on ... looks like an 80s' disco hall.

The temperature gauge is not moving at all, HU says water is cold, both engine bay fans are running at full speed. Its winter here now, so that may be related to the freezing temp and overzealous cooling.

And my nose is telling me the exhaust smells after rotten egg a bit more than I would like it.

Called the dealer, his first question was about fuel cap. So naturally i went out, cleaned the seals and resealed it tight, disconnected the battery and will leave it overnight, will update you in the morning. Their first available service time slot is December 12th, lovely! People should lean to change their own dang tires and wheels.

Nothing is blocking the Eyesight cameras, just in case anyone asks.

Anything else that might have been the culprit of this Friday FUBAR evening?
 

Attachments

·
Super Moderator
Outback 2011 3.6R Premium (sold Jan 22)
Joined
·
4,415 Posts
Most likely the gas cap as already advised.

Seagrass
 
  • Like
Reactions: David in Norcal

·
Registered
2020 OB Touring - Canadian version
Joined
·
16 Posts
Discussion Starter · #4 ·
I've been reading posts for an hour now and the fact that the engine never heats up points to TCV assembly failure. There is a lengthy thread over at Forester site with the same symptoms. Ugh!
I don't have code reader handy but will try to find someone who can read the code for me.
 

·
Premium Member
2020 Onyx
Joined
·
19,580 Posts
It's supposed to leak test the gas tank about 5 hours post shutdown and that's when it's supposed to cause all the warnings. 🤷‍♂️
 

·
Registered
20 Outback Premium; former 19 Outback Premium, 85 GL Wagon, 87 GL-10 Wagon
Joined
·
3,636 Posts
I've been reading posts for an hour now and the fact that the engine never heats up points to TCV assembly failure. There is a lengthy thread over at Forester site with the same symptoms. Ugh!
I don't have code reader handy but will try to find someone who can read the code for me.
That makes sense. The fans stuck on and the temperature stuck on cold are big clues.
 

·
Registered
2021 MGM Outback 2.5i Premium with Tungsten Grey seats
Joined
·
4,252 Posts
There is a lengthy thread over at Forester site with the same symptoms.
There's also a thread here discussing this valve...
 

·
Registered
2020 OB Touring - Canadian version
Joined
·
16 Posts
Discussion Starter · #10 · (Edited)
The little Amazon OBD2 scanner showed up, car is throwing MIL code P26A3/P2682. Yep, it's the TCV assembly. Calling the dealer in the morning. Should I start taking bets on who's gonna predict the parts waiting/delivery time?
 

Attachments

·
Registered
2020 OB Touring - Canadian version
Joined
·
16 Posts
Discussion Starter · #13 ·
I have to say I’m impressed by my local dealer. Car died November 17th. Called the dealer the next day with symptoms, confirmed the failure code on 22nd and the car was fixed on 24th. They actively preordered few replacements expecting these issues and I’ve got lucky to get one of them right away. Hats off.
 
1 - 13 of 13 Posts
Top