Subaru Outback Forums banner
  • Hey everyone! Enter your ride HERE to be a part of December's Outback of the Month Challenge!
1 - 17 of 17 Posts

·
Registered
Joined
·
6 Posts
Hi there, I have installed these on my FXT17 and OB18. They're a lot cheaper, and provides far more color and pattern options. Easy hookup. Used a fuse tap to power two front, and two rear footwells.

ebay.ca/itm/LEDGlow-6pc-96-LEDs-MILLION-COLOR-LED-INTERIOR-GLOW-ACCENT-CAR-LIGHTS-w-REMOTE/272705559373

P.S. I can't post URLs yet because of my low post count. Copy and paste the above into your browser.
 

·
Registered
'17 Outback Limited 3.6R in Venetian Red.
Joined
·
653 Posts
I have the Diode Dynamic blue footwell illumination kit and haven't installed it yet. There are no directions given for the Outback. Not sure where to start.
 

·
Registered
Joined
·
2 Posts
Hey all, I've got a 2017 Outback. Needed a new battery about 2 months ago and after the battery was changed I noticed the blue footwell lighting no longer worked. Any ideas or suggestions on how to fix? Not sure what is wrong or if a fuse blew. Nothing else with the car isn't working. Suggestions welcome. My husband isn't handy so this falls to me to fix!
 

·
Registered
Joined
·
10,936 Posts
Hey all, I've got a 2017 Outback. Needed a new battery about 2 months ago and after the battery was changed I noticed the blue footwell lighting no longer worked. Any ideas or suggestions on how to fix? Not sure what is wrong or if a fuse blew. Nothing else with the car isn't working. Suggestions welcome. My husband isn't handy so this falls to me to fix!
check the illumination level wheel setting for the interior lights with the headlights ON. See if they come on/respond.

Press the hazard switch, make sure it's working (that's where the power for the footwell lights comes from - they tap into the connector going to the hazard switch).
 

·
Registered
Joined
·
2 Posts
check the illumination level wheel setting for the interior lights with the headlights ON. See if they come on/respond.

Press the hazard switch, make sure it's working (that's where the power for the footwell lights comes from - they tap into the connector going to the hazard switch).
Tried those things - no footwell lighting with lights set to ON or AUTO while adjusting the interior lighting dial. Hazard lights work just fine. The rest of the interior blue lighting (in the door handles, in the little console area where the USB/charger area is) works.

That's why I've been so irritated about this - I've read the forum posts about the weird fuse that controls a lot of the interior stuff and it doesn't appear that a fuse blew because everything else works fine.

Sigh.
 
1 - 17 of 17 Posts
Top