Subaru Outback Forums banner

1 - 5 of 5 Posts

·
Registered
2002 Base OBW H4 Winter Package
Joined
·
98 Posts
Discussion Starter #1
05 LL Bean 101K miles, bought this for my son who is going to school and working in Lynchburg VA. 3 hours away. Good maintenance records but it is a used car.
I replaced the A/C clutch because the old one sounded like a can of rocks, the bearing was toast. Now with the A/C on, the idle surges, maybe 200-300 rpm. It’s rock steady with the A/C off.
I’ve also noticed that when revved to around 2000 rpm, the engine will stumble or stutter a bit, not enough to call a miss but I notice it under no load.
My son says that sometimes it’s jerky under acceleration, so I believe it’s the same thing.
Other than this it runs great, temp is rock steady, more power than the 02 Outback in my profile picture, that one has a used 90k engine with new head gaskets and tb replaced.
It also has a CEL, P0420, cleared once and returned, so I started by replacing the down stream 02 sensor, (Denso) but the light was still on after his 200-mile trip back to Lynchburg.
I’ve checked for exhaust leaks, found and replaced a bad muffler but the rest of the system is ok.
Replaced the PCV valve, (Subaru) and battery, cleaned the MAF and MAP sensors, air filter is new.
I don’t really want to do the $5.00 fix because I am suspicious the surging may be related and would prefer not to band-aid it. I also was thinking possible vacuum leak but am leaning away as the idle with A/C off is fine.
So, I’m thinking in order:
Plugs, wires, coil then front 02 sensor and new cat as a last resort.
It’s difficult to diagnose when he can only get home one weekend a month, but I will have more time when he comes back for a week before school starts again.
So, any suggestions or sensors to check would be appreciated, I’m a pretty accomplished weekend mechanic, and he does have a code reader.
Posted this on the Forester board and an idle re-learn proceedure was suggested which I'll get my son to try.
But any suggestions would be appreciated.
Thanks
John
 

·
Registered
03 H6 OBW & 06 WRX Sportwagon
Joined
·
17,705 Posts
yeah - plugs and plug wires, check for oil on wire boots, knock sensor might be cracked. DO NOT replace the cat without FIRM diagnosis.

getting live data will be helpful. Check into an OBD app for a smartphone and an ELM327 BT adapter(cheap, BAFX or Veepeak from amazon).

should have already had a timing belt system service 4-5 years ago - if it hasn't it's way overdue.
 

·
Registered
2002 Base OBW H4 Winter Package
Joined
·
98 Posts
Discussion Starter #3
Seller's brother owned a shop where the maintenance was done, tb and head gaskets at 90K. I'll see if I can get my son to capture live data, not sure what app he downloaded, what am I looking for?

Thanks

John
 

·
Registered
03 H6 OBW & 06 WRX Sportwagon
Joined
·
17,705 Posts
others will have better ideas but, Fuel Trims, would be a good place to start .

I'm no expert and would have to ask for myself!
 

·
Registered
2002 Base OBW H4 Winter Package
Joined
·
98 Posts
Discussion Starter #5
Update, had him clear the code and do the idle re-learn, from the Forester Fourm, Saturday. He said it smoothed out the idle and so far no return of the P0420, but he only drives about 15 min to work each way. We shall see when he comes back up to NVA in 2 weeks.
I have plugs, wires and a front O2 sensor waiting inthe wings.
 
1 - 5 of 5 Posts
Top