Subaru Outback Forums banner

1 - 7 of 7 Posts

Registered
2004 35th Anniversary Outback - H6
Joined
164 Posts
Discussion Starter #1
i've posted these before on a few other sites but they had issues on the server i was posting on... this seems to be just like a site i post on another site.

anways heres on mod on a custom intake i pieced together
 

Attachments

SubaruOutback.org Founder
2018 Outback Limited 2.5L - 105,000+ miles
Joined
5,106 Posts
I'm guessing you used 3" piping, it looks kind small as compared to mine though. Well its probably because your filter looks much larger than mine, must be that. And yours is much cleaner than mine also :p

 

Registered
2004 35th Anniversary Outback - H6
Joined
164 Posts
Discussion Starter #3
yeah its a 3 incher so its small then yours i'd say.. i would say that sometimes the open filter can cause a slight bog if you really get on it from a slow roll.
 

Registered
2004 35th Anniversary Outback - H6
Joined
164 Posts
Discussion Starter #4
btw is that salt residue on your engine cover?
 

SubaruOutback.org Founder
2018 Outback Limited 2.5L - 105,000+ miles
Joined
5,106 Posts
MaverickOutback said:
yeah its a 3 incher so its small then yours i'd say.. i would say that sometimes the open filter can cause a slight bog if you really get on it from a slow roll.
My piping is actually 3" also, you must have a much larger filter on yours. Your's bogs when you hammer it?!? Jeez, my setup has increased my low end and take off significantly. No bog, no lag just that sweet, silky smooth torque and loud sucking sound :D
 

Registered
Joined
194 Posts
MaverickOutback said:
btw is that salt residue on your engine cover?
I am guessing it is. My engine looks the same through winter.
 

Registered
turbo ej22t STI 5spd sport
Joined
20 Posts
woow all that room for a twin turbo kit:p :p :p
 
1 - 7 of 7 Posts
Top