Subaru Outback Forums banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Outback of the Month Challenge!
1 - 2 of 2 Posts

·
Registered
Red 2002 AT Outback, Red 2003 Forester, Green 2006 outback All stock, 2006 not running
Joined
·
6 Posts
Discussion Starter · #1 ·
Yep ANOTHER FNG (friggin new guy). I have been a Subaru fan for the past 7 Years and can't say enough about them. My first was a 1999 Forester L which I paid $400.00 for at a car lot. It was a 5 speed, had a dent where the driver door and fender meets and the engine was "blown" according to the lot owner. So I started it up and trailered it home. The "blown engine" turned out to be bearings missing from the toothed idler. After installing a belt kit, it was smooth as silk and 28 mpg. Ah, those were the good old days. Last December around 1:00am Bambi's distant relative stepped in to my path on I-95 while I was at speed (70 mph). The airbags did NOT deploy and I drove another 8 miles home to remove 3 hands full of "deer innards". That was then and this now. I have another Subaru and its an Outback. Yes, it has issues and I'll post them in the forum.

I am twice retired, Military then John Deere. Not married and have a 94 Mazda MPV and a 2005 Kawasaki ZG1000 Concours. Yep, I like to turn wrenches on older cars.
 

·
Registered
2018 Dark Blue Outback 3.6R Touring arrived 8/31/2017
Joined
·
343 Posts
Your big mistake in the deer incident was not driving long enough with a hot Forester (seems fitting for a forester to kill a deer somehow!) to cook it properly :p

Welcome to the online extension of the Subaru cult!
 
1 - 2 of 2 Posts
Top