Subaru Outback Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter #1
Greetings,

I have Subby outback 2000 2.5. Now I have driven this car in Europe for over 4 years mainly on LPG. I noticed that after start in the morning when waiting on a traffic lights, the RPM will drop to less then 500 and from time to time the engine will stall. I noticed that every morning when engine is cold, after few minutes of running, I will have this symptoms on first traffic lights ever day now.

After running longer for 10 minutes when the engine gets, I guess normal operating temperature, it is fine and will not stall. The RPM will stay at normal level on traffic lights. As I mentioned I drive the car on LPG. First I observed that on LPG after the engine switches from Gas to LPG and thought it is related to LPG but to eliminate LPG from the equation I drove the car on Gas all the time and has same symptoms while driving on Gas, although I must say less frequently. But no matter on what fuel I drive, it will stall on my first traffic lights. Then it will be fine, I will manually switch to LPG and it is fine on next traffic lights.

Any idea of the issue? Perhaps some temperature sensor, some vacuum? I would appreciate your advice. Hopefully no need to change any parts/sensors as I will need to be importing from USA.
 

·
Registered
Joined
·
2,342 Posts
First thing that came to mind was spark plugs. First thing I'd check would be a vacuum leak.

Did you do the conversion to LPG or did you have it done? I'd love to look at that set up. Most gas vehicles are not really built to handle LPG for extended periods so I'm guessing some mods came into play. If not, well you might be experiencing those types of problems now.

Do you have any codes (even if the light isn't on you might still have a code stored)? PVC, vacuum leak, sensors, lots of things really could come into play.
 

·
Registered
Joined
·
36 Posts
Discussion Starter #3
Hi Dave,

Thanks for your advice. I have had the LPG installation done over 3 years ago by LPG authorized shop. Here in Poland LPG is very popular due to high gas prices. In general gas here costs more than double then in US and LPG is less than half of gas. These days the LPG installations are very advanced and have lot of electronics, injectors etc. I have been very pleased with this installation. Of course it requires more often service, like for instance every 10k km I need to change air flow LPG filter and every 30K km a liquid flow LPG filer, other than that very reliable and no issues. I have seen cars running over 10 years on LPG and little Fiats, VW or Renault done over 200K km on LPG alone. I have just done service a month ago as I had some symptoms running on LPG only. I changed sparkplugs, changed both filters and it was great improvements in performance as well as LPG millage. Normally I would go to my LPG specialist if it was only LPG problem but since I have these symptoms running on gas as well, it is not related to LPG alone, at least what I think so. Of course LPG is more sensitive but again after running for 10 minutes all is good.

Just this nuance know. If you want to see some photos of my LPG installation just let me know. I can take and upload some. The engine light comes and goes.. I stopped paying attention to the engine light as it will come ON when the LPG needs service. So I would have LPG serviced and then it is happy until next time. So yes I can try to read the codes and see what it says.
 

·
Registered
Joined
·
2,342 Posts
Cool to hear!

If all else fails you could have the ECU flashed for a higher rpm, but I suspect that would be an expensive and temporary fix.

I'm always fascinated by LPG conversions, here in the US it isn't really cost effective to do it but there is a small group of people that like to tinker and make their own as a hobby. When I was seventeen I was tasked with getting a dodge truck to convert to LPG. It was a fun project.

If you can't figure it out you might want to run by that shop. Unfortunately they maybe the only ones that can help you. Hopefully someone else can way in too.
 

·
Registered
Joined
·
16,966 Posts
Engine Temp Sensor may not be boosting the mixture when cold. (this used to be a separate sensor than the Temp Gauge Sender - may be combined in your car)
 

·
Registered
Joined
·
52 Posts
like novablue said check for vaccum leaks. hoses are les flexible and contract in colder temperatures allowing for small cracks to be become an issue. as the temps rise the hoses expand and become more flexible. if this is the problem it can be a cheap and easy fix. good luck to you
 

·
Premium Member
Joined
·
11,882 Posts
like novablue said check for vaccum leaks. hoses are les flexible and contract in colder temperatures allowing for small cracks to be become an issue. as the temps rise the hoses expand and become more flexible. if this is the problem it can be a cheap and easy fix. good luck to you

The fault code(s) stored in memory is the best place to start.

If it is getting to freezing where you are, check the vacuum hose that goes from the intake to MAP sensor for icing.

Check the front Oxygen Sensor output. It is actually an A/F sensor for fuel trim. Look to see if you can see a crack in the porceline. There was actually a recall in the States for the front O2 sensor dealing with cracking in the sensor for the automatic models.

Fuel quality: Cheap fuel with water???? High alcohol content????? Subarus don't like alcohol blends and will suffer in cold temperatures until the engine temperature is up to aid in burning the alcohol.

You might also want to check the battery and alternator. Poor amp flow will make the car run poorly.
 

·
Registered
Joined
·
36 Posts
Discussion Starter #9
Hi Cardoc,

Thanks for your advice. I will try to read the codes, maybe even this afternoon. Actually the weather here is not cold yet. It is fall but it is nice and pleasant, This morning when I was leaving home around 8 am was 62 in F. but normally in the morning at this time of the year is around 50 in F. So not too cold yet. I did replaced the O2 sensors about 1.5 ago. I ordered them from US, universal aftermarket but never had any problems since then. The fuel quality is not that bad here, plus dont forget even the cheapest gasoline here has more octanes then the premium in US :), so I think my Subby never complained about the gasoline here. I mainly drive on LPG but obviously the cars starts on gas before it switches to LPG. The symptoms are bigger on LPG probably for the fact that LPG has less octanes then gasoline. but again i drove my Subby for over 3 years now on LPG and very happy with the performance.

I need to inspect the vacuums and will check the O2 sensor. Any advice from you on a technique to identify a bad vacuum?
 

·
Registered
Joined
·
2,342 Posts
My preferred method is a smoke tester, but seeing as you don't have one (who does? well cardoc might ;) )

How To Find A Vacuum Leak - EricTheCarGuy - YouTube

Sorry about the annoying video...

Ironically LPG is one method which is why I included that video (I know you might have access to LPG). Please don't use carb cleaner like this guy does. If you must make sure you have a friend [That you trust] with the fire extinguisher at the ready. Too many things in old cars can ignite that stuff, even subies.

I need to learn how to embed video...
 

·
Premium Member
Joined
·
11,882 Posts
Hi Cardoc,

....... I ordered them from US, universal aftermarket but never had any problems since then.

I need to inspect the vacuums and will check the O2 sensor. Any advice from you on a technique to identify a bad vacuum?

You need to replace the oxygen sensors with OE fit sensors. Universal oxygen sensors never work for long. Reason being is in the manufacture of the sensor for "universal" installation. The interior pressure of the sensor is never correct and sends an incorrect reading to the computer.

See Oxygen sensor - Wikipedia, the free encyclopedia for more on Oxygen sensors.

As far as the vacuum leak check: Without a system smoker to locate leaks, your stuck with listening for a "whistle" or visually checking for cracks and loose connections on all the hoses.
 

·
Registered
Joined
·
36 Posts
Discussion Starter #12
Hi guys,

Thanks for looking at my post and all your advices. Problem solved. It turned out that there was no issue with leaking vacuum, no issues with any sensors, O2 and all my suspicions. Found a subaru mechanic who adjusted valves and all problems went away. The car runs like a champ, very smooth, so responsive to acceleration. I am shocked by the performance improvements, not mentioned way better mileage.

Regards,
 
1 - 12 of 12 Posts
About this Discussion
11 Replies
5 Participants
zxj24
Subaru Outback Forums
Welcome to the Subaru Outback Owners Forum, we have tons of information about your Subaru Outback, from a Subaru Outback Wiki to customer reviews.
Full Forum Listing
Top