Subaru Outback Forums banner

Spotify not working?

208 3
2022 OBW - Spotify doesn't seem to be working with Carplay - all functionality is there, I can see music & pods in Spotify, seems to be up-to-date info (new pods are visible), but when I press play, it just won't play - the "play now" screen is blank, the buttons are there, but the track info & all of that is blank

I'm really frustrated with Carplay & the infotainment system in this car - why is everything so **** glitchy?
1 - 4 of 4 Posts

·
Registered
20 Outback Premium; former 19 Outback Premium, 85 GL Wagon, 87 GL-10 Wagon
Joined
·
3,636 Posts
2022 OBW - Spotify doesn't seem to be working with Carplay - all functionality is there, I can see music & pods in Spotify, seems to be up-to-date info (new pods are visible), but when I press play, it just won't play - the "play now" screen is blank, the buttons are there, but the track info & all of that is blank

I'm really frustrated with Carplay & the infotainment system in this car - why is everything so **** glitchy?
Do other audio apps play properly through CarPlay? How about CarPlay on another vehicle? Yes, sometimes the problem is the vehicle, but sometimes it's the phone or the app itself. There is currently a bug with Google Maps that appeared with ios16 using Bluetooth without CarPlay, probably won't be fixed for several months based on past experience.

I don't use Spotify, but can confirm that other functionality with CarPlay has been flawless since doing the October 2022 update. With the April 2022 update, the only issue I was having is CarPlay occasionally disconnecting and then reconnecting within a few seconds, but now with the October 2022 update I haven't had any glitches with the head unit or CarPlay.
 

·
Registered
2022 Outback Wilderness
Joined
·
15 Posts
I’m using CarPlay (wireless with adapter) and haven’t had issues with Spotify or anything so far.

Have you looked at your CarPlay settings on your iPhone to see what cars it has registered or to see if there are any other settings you can tweak? Do you have any sort of iOS “Focus” times that would affect certain things at certain times? Maybe try restarting your iPhone?

Biggest issue for me was setting up wireless CarPlay after using wired. Connection wasn’t working. I had to go to CarPlay settings, clear my OWB from it and also remove my OBW from my iPhone’s Bluetooth. Then I let everything speak to each other from scratch. Perhaps you could try clearing the CarPlay settings like I did and see what happens when you plug your phone back in. Maybe a fresh connection would help.

Good luck!
 

·
Registered
2022 Outback Wilderness - Geyser Blue
Joined
·
34 Posts
Discussion Starter · #4 ·
Update: I went thru to make sure all my settings were correct - then I went back to my car & checked to see if Spotify worked via BT to the native media player & it did the same thing (can see all the media, but will not play)

I uninstalled Spotify from my phone & reinstalled & it still didn't work - then I shut down my car, opened Spotify on my phone, then restarted the car & Spotify worked. I shut down the car & closed Spotify on my phone, fired up the car & Spotify wouldn't work... Again, this AM I opened Spotify on my phone before starting the car & it worked fine... So, I guess I have to have Spotify open on my phone before connecting to Carplay

My only guess is maybe the recent update to iOS16 is causing this, but it doesn't appear others are having this issue, so it's kinda a head-scratcher - maybe also b/c I'm still rocking a iPhone 8...

But, the infotainment center & Carplay have performed so poorly on this car since Day 1, so none of this is really surprising...
 
1 - 4 of 4 Posts
Top