Subaru Outback Forums banner
  • Our 4th of July contest is live! Enter HERE for your chance to win a $400 Walmart gift card.
  • Hey everyone! Enter your ride HERE to be a part of this month's Outback of the Month Challenge!

1 - 8 of 8 Posts

·
Registered
2016 3.6R Outback; tungsten metallic with E/S and every option. I also have a Samsung Note 8 smartphone for trouble-free Bluetooth functionality.
Joined
·
1,367 Posts
Discussion Starter · #1 ·
I just returned from a 4100 mile trip for a shootingcompetition in Ottawa. My 3.6 did verywell but developed a problem with the battery while in Ottawa. I took it to a local Subaru dealer oneafternoon and they diagnosed the battery as bad and replaced it at no cost tome. This took less than one hour. I was extremely pleased.

The 3.6 was a joy to drive there and back and I used thehell of the LKA and ACC. The 3.6 wasfilled to capacity with my gear, yet ran like a champ. On the way back, I convoyed with a 2.5 for awhile; it was fun to see it try to keep up at times, north of 75MPH, but it didfine since there was only one person in it.

I averaged 27.6MPG displayed, and for one tankful, Iactually averaged 30MPG going from Columbus, OH to Rochester, NY. I was impressed.
 

·
Super Moderator
2016 3.6 Limited with ES
Joined
·
2,913 Posts
You haven't been on the forum in some time. You must have driven very slow.
 

·
Registered
2016 3.6R Outback; tungsten metallic with E/S and every option. I also have a Samsung Note 8 smartphone for trouble-free Bluetooth functionality.
Joined
·
1,367 Posts
Discussion Starter · #3 ·
This site is so bad, so loaded with crap and ads that it ispainful to come here and try to read stuff, let alone post anything. I wrote my OP in Word then copy/pasted thetext to the site because it simply refuses to let me type at anywhere near myspeed. The webpage eats letters whentyping and then when you type more, it just stalls then all of a sudden itstarts accepting characters again.
The only thing I wrote directly here was the title and itate up “ba” in “back” and left “ck” behind.

Even this response was keyed in Word first while the webpagecontinued to jiggle and add more crap.

Very frustrating, so I stay away.
 

·
Premium Member
2015 Legacy 3.6R ES, 2014 Forester Touring ES, 2005 Jeep Liberty Limited
Joined
·
3,243 Posts
Try running Tapatalk as the Front End. It makes a world of difference. I also became frustrated trying to use their Web Front End for these Forums and definitely a weak and cumbersome.

Laughing at Oneself and with Others is Good for the Soul
 

·
Banned
Joined
·
6,264 Posts
Had the same issue until I started using an ad blocker. World of difference.
 
  • Like
Reactions: 1454 and ammcinnis

·
Registered
2017 3.6R Outback Touring
Joined
·
9 Posts
Yeah if it wasn't for Adblock and noscript I wouldn't even visit this place... A quick look at noscript shows it trying to load scripts from 25ish other sites...

-pd
 

·
Registered
2015 3.6R Limited w/ES
Joined
·
3,814 Posts
I found a suggestion to use the dropdown at the bottom of the page, left side, and select "classic" as the style. Looks crappy, but it's a lot faster on my old laptop. Somewhat recently (few months ago maybe) I noticed the CPU revving up like crazy in "full" (fan running strong), along with sluggish response.
 

·
Registered
2016 OB 3.6R - Carbide Gray
Joined
·
1,297 Posts
Yeah if it wasn't for Adblock and noscript I wouldn't even visit this place... A quick look at noscript shows it trying to load scripts from 25ish other sites...

-pd
It's sad that there are so many sites like that. I know sites stay alive because of ads, but you don't have to make them quite so annoying. Speed is the main reason I use adblock.
 
1 - 8 of 8 Posts
Top